Fichier d'aide pour Cumulus v1.9.4

Fichier d'aide

Version 0.5 - Novembre 2013

Logo de Cumulus Weather Software

Ce document se veut une traduction libre du fichier d'aide anglophone inclu avec le logiciel Cumulus. Cette traduction se veut libre en ce sens qu'elle reprend l'intégralité du fichier original et en fait une adaptation pour la communauté francophone de Cumulus.

La traduction se veut respectueuse de la terminologie informatique selon le Grand dictionnaire terminologique de l'Office Québecois de la Langue Française, mais sans chercher à perdre le sens du texte original.

Ce fichier d'aide est basé sur la précédente version framçaise officielle (v0.2 - May 5, 2011) du site Internet de Cumulus, à l'adresse suivante Sandaysoft. Ce fichier a été mise à jour et adapté pour la version 1.9.4 de Cumulus. Les adaptations et traductions françaises disponibles ont été intégrées au présent document.

Pour vous aider dans votre lecture, voici la logique utilisée:

'italique et apostrophe' indique un terme affiché par Cumulus et non traduisible.

Gras indique un terme fort dans Cumulus, qui serait malvenu de traduire.

En bleu Indique une balise ou une commande de Cumulus

Finalement, je vous invite à me joindre pour signaler une erreur, laisser un commentaire ou une suggestion à l'adresse suivante: jacques.desroches@meteoduquebec.com, ou encore mieux, laissez-moi un message dans le Forum


Fichier d'aide pour Cumulus v1.9.4

Logo de Cumulus Weather Software

Introduction

Dans cette section, nous prenons connaissance de Cumulus v.1.9.4, logiciel de gestion pour Station Météo Personnelle développé par Sandaysoft.

L'introduction comporte 6 sections, à savoir:

  • Accord de Licence - Les termes d'utilisation de Cumulus
  • Introduction à Cumulus- Description du logiciel et des Stations supportées.
  • Contacts - Comment contacter Cumulus?
  • Démarrage - à lire ABSOLUMENT avant de démarrer.
  • Remerciements - aux gens qui ont participé.

Version 0.5 - Novembre 2013


Accord de Licence

Licence

Cumulus est gratuit pour une utilisation personnelle non commerciale. Vous pouvez utiliser ce logiciel gratuitement, tant que vous n'en n'obtenez pas de gain financier, direct ou indirect. Vous ne pouvez pas modifier, ou reconstituer le code source du logiciel. Vous ne pouvez pas distribuer de copie de ce logiciel sous une forme autre que son format original. Vous ne pouvez pas distribuer ce logiciel avec un autre logiciel ou un matériel.

Cumulus est fourni tel quel. Aucune garantie n'est assurée, expressement ou implicitement. Vous utilisez ce logiciel à vos propres risques, L'auteur ne saurait être tenu responsable d'aucun dommage ou perte subis par l'utilisation de ce logiciel.

En utilisant ce logiciel vous acceptez de ce fait, les termes de cet accord.

Ce logiciel et les fichiers associés sont protégés par copyright © Sandaysoft 2012.


Introduction

Qu'est ce que Cumulus?

Cumulus est un logiciel pour charger, stocker et afficher les données en provenance d'une station météo automatique (AWS). Il fonctionne avec les stations suivantes :

  • Oregon Scientific WM918
  • Oregon Scientific WMR918/WMR928/WMR968
  • Oregon Scientific WMR88/WMR100/WMR200
  • Radio Shack/Huger WX200
  • Davis Vantage Pro, Pro2 et Vue
  • Fine Offset et modèles sous licence - WH1080, WH1081, W8681, 265NC etc etc
  • La Crosse WS2300 et autres dans cette gamme

Si vous trouvez Cumulus pratique, et si vous souhaitez faire un don pour aider son développement futur, vous pouvez l'envoyer via Paypal, en cliquant sur le bouton ci-dessous. Vous n'avez pas besoin d'être titulaire d'un compte Paypal, vous pouvez régler par carte de crédit.


Nous Contacter

Vérifiez la FAQ, pour voir si votre question n'a pas déjà été répomdue (en anglais).

Il y a également un Forum ou vous pouvez rapporter des bogues, suggérer des améliorations et débattre de Cumulus. (toujours en anglais)


Démarrage

Branchez votre station météo à un des ports série (ou USB) de votre ordinateur, puis démarrez la station. Assurez-vous de toujours relier votre station météorologique à votre PC et de la mettre en fonction, avant de démarrer Cumulus. Quand vous lancez Cumulus pour la première fois, l'écran 'Station Settings' (paramètres de la station) apparaît. Vous devez au minimum spécifier votre type de station (Station Type), et pour les stations série, le port de communication utilisé (COM Port). Vous pouvez y ajuster les paramètres, et entrer les informations sur votre localisation. Consultez le sujet Configuration: Station pour plus d'information.

Il est important de noter que vous devez choisir vos unités de mesure au premier démarrage de Cumulus, par la suite ces paramètres ne doivent pas être changés. Les données sont enregistrées selon le format des unités de mesure choisies, alors si vous les modifiez par la suite, vos données n'auront plus de sens.

Lorsque vous avez entré les valeurs correctement, cliquez sur OK, et la fenêtre principale de Cumulus apparaitra.

Si votre station est munie d'un enregistreur, Cumulus y puisera ses données à chaque lecture, à l'exception de la toute première lecture, puisqu'il n'y a pas de lectures antérieures.

Si vous utilisez Vista ou Windows 7, vous rendrez les choses plus simples si vous n'installez pas Cumulus à l'emplacement par défaut (sous Program Files), car Vista cachera vos données quelque part sur votre disque. Installez plutôt Cumulus en dehors du dossier Program Files

À chaque démarrage, Cumulus prend une copie de sécurité de vos données et les met dans le dossier backup; dans un fichier nommé au format yyyymmddhhmmss. En tout temps, si vous trouvez des données erronées, vous pouvez arrêter Cumulus et le 'reculer' en utilisant la copie de sécurité appropriée pour remplacer les données courantes dans le dossier data. Cumulus téléchargera de nouveau les données à partir de votre station (en supposant que votre station est munie d'un enregistreur), ce qui pourrait corriger vos données

Cumulus garde les dix dernières copies. Ne créez pas vos propres fichiers ou dossiers dans le dossier backup, car ceci interférera avec le mécanisme de secours


Remerciements

Mes remerciements à :

  • Beth pour ses encouragements, et les merveilleuses pages web.
  • Paul Crabtree, David Jamieson, Marc Dupuis, Harry Bloomfield et tous les autres testeurs.
  • Michael Pendec et Jim Easterbrook pour leur aide avec les données d'Easyweather/FineOffset
  • Mathias Rauen pour le gestionnaire d'erreur 'MadExcept'.
  • Martin Stoeckli pour l'aide 'HTML' et les routines 'Version Number'.
  • Troels Jakobsen pour le composant 'CoolTrayIcon'.
  • Olivier Touzot pour le composant TQSpiderGraph.
  • François Piette pour l'Internet Component Suite. (Je dois toujours lui envoyer une carte postale!)
  • Adrock Software pour le composant Timerlist.
  • Robert Marquardt RIP pour le composant USB
  • Erik Van Bilsen pour la librairie GDI+
  • Beetlejuice pour l'algorithme des prévisions
  • Steve Hatchett pour quelques-une des routines de calcul des données.
  • Mark Crossley pour ses modules d'extension web et pour avoir tenu le wiki à jour.
  • Tous ceux qui ont été assez gentils pour faire un don et tous ceux qui ont aidé pour le wiki.
  • Et tous ceux que j'oublie

Traduction:

  • koi-2-9 pour la traduction complète du fichier de la version 1.8.7
  • Jacques DesRoches pour la mise à jour pour la version 1.9.4


Section : Configuration

Logo de Cumulus Weather Software

Configuration

Dans cette section, nous explorons la configuration de Cumulus.

La section configuration comporte 5 sections, à savoir:

  • Station - Renseigner Cumulus sur votre installation
  • Affichage- Les paramètres d'affichages
  • Internet - Paramètres Internet pour afficher sur le Web
  • Calibration - Ajustements possibles pour augmenter la précision.
  • Personnalisation - Adaptations et traductions.

Version 0.5 - Novembre 2013


Configuration de la Station

(Menu: CONFIGURATION - STATION)

Cet écran vous permet de fournir les informations sur votre station météo et votre localisation.

Station Type

Sélectionnez la marque et le modèle de votre station météo. Le paramètre EasyWeather est une alternative (obsolète) pour les stations qui utilisent le logiciel EasyWeather (Fine Offset, MyDEL, Nevada, WH1080 etc) et est utilisé quand vous exécutez Cumulus et EasyWeather en même temps. De cette manière, Cumulus peut récupérer les informations depuis le fichier de données de EasyWeather. Il est préférable de plutôt choisir le paramètre 'Fine Offset etc' pour ces stations, car Cumulus pourra ainsi contrôler directement la station, mais vous ne devez pas exécuter EasyWeather en même temps si vous choisissez cette dernière option. Notez que si vous devez utiliser l'option EasyWeather, vous devrez utiliser EasyWeather ET Cumulus simultanément, 24h/jour, 7/7j, sans interruption. Autrement, vous générerez des "trous" dans vos données, ce qui enlèvera tout sens à vos statistiques. Il est fortement recommandé de ne PAS utiliser l'option 'EasyWeather'.

Si votre modèle précis de station n'est pas listé, vous devrez probablement choisir 'Fine Offset'.

Si vous avez une station WH3080 ou WH3081, ou n'importe quelle autre station 'Fine Offset' qui inclue les sondes UV et solaires, vous devez sélectionner 'Fine Offset with UV/Light sensor'. Notez qu'il y a quelques stations 'Fine Offset' qui ont un chargeur solaire pour les piles; ce n'est pas la même chose qu'avoir des capteurs solaire et UV. Si votre station a un chargeur solaire mais n'a pas les sondes solaires et UV, employez le paramètre Fine Offset 'normal', et non le paramètre 'Fine Offset with UV/Light sensor'.

Pour les stations Oregon Scientific et les stations semblables sous licence (Huger, Radio Shack etc.) qui ont une connexion par porte Série, si votre modèle n'est pas énuméré, essayez WM-918 si votre station a une connexion par câbles, et WMR-928 si elle est sans fil.
COM Port Port de communication Série
Indiquez sur quel port COM est branchée votre station. Vous n'avez pas besoin de configurer un port Série (COM port) pour les stations Fine Offset ou Oregon Scientific USB (WMR100 etc).

SETTINGS:
Use bearing zero when calm Indiquer la direction '0' lorsque le vent est calme
Cochez pour que Cumulus affiche zéro comme direction (et '---' pour le point de boussole) quand le vent est calme, autrement il affiche la direction lue de la station (c'est-à-dire la dernière direction du vent avant que le vent se calme). Notez que la direction moyenne du vent affichera toujours la direction zéro s'il n'y a eu aucun vent depuis les 10 dernières minutes, la direction moyenne tenant compte de la vitesse de vent.
Calculate 10-min wind average Calcul la vitesse du vent selon la moyenne des dernières 10 minutes
Cochez pour que Cumulus calcule et affiche la vitesse moyenne du vent, sur 10 minutes, au lieu d'utiliser la valeur fournie par la station. Normalement utile seulement pour les stations Oregon Scientific et Fine Offset, puisque ces stations fournissent une vitesse de vent moyenne basée sur les quelques dernières secondes seulement. Les stations Davis fournissent une moyenne de 10 minutes directement.
Use 'speed' for avg calculation Utilise 'speed' pour le calcul de vent moyen
Généralement les stations fournissent deux vitesses de vent; une vitesse à court terme, que Cumulus appele 'Latest' et une vitesse à long terme, que Cumulus nomme 'Average', sauf si l'option 'Calculate 10-min wind average' est cochée, dans ce cas, Cumulus calcule une moyenne sur 10 minutes en utilisant la valeur à court terme 'Latest'. Si vous cochez cette option, Cumulus utilisera plutôt la valeur à long terme 'Speed' dans le calcul. L'option 'Use 10-min average wind speed' doit être cochée pour que cette option fonctionne.

Notez que la vitesse 'à court terme' des stations Fine Offset est la valeur de 'gust' (c.-à-d. Le plus haut échantillon sur une période de 48 secondes, et tandis qu'il peut sembler incongru d'employer ceci pour calculer la moyenne, beaucoup de gens constatent que ceci donne un bon résultat. Cependant, vous trouverez peut-être que sélectionner cette option pour utiliser la seconde valeur du vent sur 48 secondes donne un meilleur résultat.

Notez qu'il n'y a pas vraiment d'intérêt à utiliser cette option pour les stations Davis, comme leur vitesse à long terme est une moyenne sur 10 minute, et aucun intérêt pour les stations La Crosse, étant donné qu'elles fournissent seulement une vitesse de vent.

Round wind speeds Arrondir les vitesse du vent
Sélectionnez cette option pour arrondir la vitese du vent à l'entier le plus près.
Use 100% for 98% humidity Indiquer l'humidité à 100% lorsque 98%
Sélectionnez cette option si votre station affiche un maximum d’humidité relative égal à 98%, et que vous souhaitez qu’il soit affiché et enregistré comme 100%. En principe, utile seulement pour les stations Oregon Scientific.
Calculate dew point Calculer le point de rosée
Sélectionnez ce paramètre pour que Cumulus calcule le point de rosée, au lieu d’utiliser la valeur transmise par la station. Ceci permet de contourner la restriction des stations Oregon Scientific qui ne peuvent pas afficher un point de rosée inférieur à 0°C.
Calculate wind chill Calculer le refroidissement éolien
Sélectionnez cette option pour que Cumulus calcule la température incluant le Facteur de Refroidissement Éolien à la place d’utiliser la valeur transmise par la station. Notez que certaines stations, Fine Offset notamment, ne fournissent pas de facteur éolien, Cumulus le calcule pour ces stations. Vous devez cocher cette option si vous avez spécifié des valeurs de calibration pour le vent ou la température, pour que Cumulus puisse aussi appliquer ces valeurs au Refroidissement éolien.
Synchronise Davis clock to PC Synchronise l'horloge des stations Davis sur celle du Pc
Lorsque sélectionné, au démarrage et à 04:00, Cumulus synchronisera l'heure de certaine stations sur l'heure du PC (recommandé). Note: Il semble que Weatherlink IP ne supporte pas cette fonction.
Use data logger Utiliser l'enregistreur de données de la station
Ce paramètre est sélectionné par défaut. Au démarrage, Cumulus téléchargera les données de l'enregistreur de données de la stations (s'il en est équipé), à partir de la dernière lecture lue lors de l'arrêt de Cumulus. Si vous ne choisissez pas cette option, Cumulus n'utilisera pas les données stockées dans l'enregistreur de la station au prochain démarrage, ainsi s'il ne fonctionne pas pendant un moment, vous obtiendrez des 'trous' dans vos données. Vous n'auriez pas besoin normalement de supprimer cette option. Si Cumulus est fermé, et que vous ne souhaitez pas qu'il charge les données au prochain démarrage, vous pouvez modifier le fichier cumulus.ini et, dans la section [Station], changer la ligne 'UseDataLogger' pour la valeur 0 (si la ligne n'existe pas, ajoutez la). Notez que le fait de modifier le fichier cumulus.ini équivaut à désélectionner cette option; n'oubliez pas de cocher 'Use data logger' de nouveau quand vous voudrez que Cumulus utilise l'enregistreur de nouveau.
Ignore La Crosse Clock Ignorer l'horloge LaCrosse
Sélectionner pour utiliser l'horloge du PC comme référence pour l'horodatage des données de l'enregistreur des stations La Crosse, au lieu d'employer l'horloge de la station parfois peu fiable.
Synchronise Fine Offset reads Synchroniser les lectures sur Fine Offset
Cette option est une tentative pour contourner le problème 'lecture USB' avec les stations Fine Offset plus récentes. Cela fonctionne en évitant la communication avec la station aux heures 'critiques', c.-à-d. quand la console met à jour la mémoire. La station fait celà à toutes les 48 secondes, et toutes les 60 secondes. Cumulus exécute une synchronisation une fois par jour, où il détermine quand la console fait ces mises à jour, ainsi il peut les éviter.
Cumulus pressure trend names Texte de Cumulus pour la tendance de la pression
Sélectionnez cette option pour que Cumulus produise le texte pour la tendance de pression actuelle, par ex. "Baisse", "Hausse lente" etc, au lieu de celui fourni par votre station. La francisation de ces termes dépends de l'installation des fichiers francisés. Notez que certaines stations ne fournissent pas la tendance, ainsi l'option n'a aucun effet pour ces stations (Cumulus produit toujours le texte pour ces stations).
VP 1-min barometer update Intervale 1 minute du baromètre Vantage Pro
Sélectionner cette option pour forcer les stations Vantage Pro (et Pro2) à actualiser la lecture du baromètre une fois par minute au lieu des 15 minutes par défaut. Notez que vous pouvez ne pas avoir besoin de cette option, puisque les stations plus récentes actualisent déjà cette lecture à chaque minute.
Extra Sensors Capteurs supplémentaires
Sélectionnez cette option si vous avez des sondes supplémentaires (par exemple une sonde de Davis pour l'humidité du feuillage) pour que Cumulus lise, affiche, et enregistre les lectures à partir des sondes. Vous n'avez pas besoin de sélectionner ceci pour les sondes Solaire/UV.
EasyWeather Interval Intervale EasyWeather
Normalement, vous n'avez pas à indiquer cette valeur. Si vous utilisez la méthode EasyWeather (non recommandée), mettez la même valeur que celle utilisée dans EasyWeather lors de la configuration de votre station.
Easyweather.dat Fichier EasyWeather.dat
Normalement, vous n'avez pas à indiquer cette valeur. Si vous utilisez la méthode EasyWeather (non recommandée), indiquez ici l'emplacement du fichier EasyWeather.dat (vous pouvez cliquer sur la petite icône répertoire, et rechercher le fichier)

Program Settings
Confirm shutdown Confirmer l'Arrêt
Si sélectionné, Cumulus enverra un message de confirmation de fermeture.
Close on suspend Fermer pendant la mise en Veille
Si sélectionné, Cumulus se fermera si vous mettez votre ordinateur en veille/Attente/Hibernation. Il est recommandé d'utiliser cette option si vous avez l'habitude de mettre votre ordinateur en veille sans fermer Cumulus. Vous devez désactiver l'option 'Confirm shutdown' si vous utilisez cette option. Notez que cette option peut causer des problèmes de temps à autre, tel que la corruption des données, vous devriez éviter son utilisation si possible. Mieux vaut s'assurer que votre ordinateur n'entre pas en veille!
Stop 2nd instance Fermer une 2e instance
Lorsque sélectionné, empêche de lancer plusieur fois Cumulus. Exige un redémarrage de Cumulus pour prendre effet.
Restart if unplugged Redémarrer si débranchée
Lorsque sélectionné, Cumulus redémarrera si une station USB est débramchée. Il peut se rétablir, aucune garantie! Utilisez avec soin. Sélectionnez judicieusement les autres options.
Restart if data stops Redémarrer si aucune données
Lorsque sélectionné, Cumulus redémarrera s'il détecte qu'aucune donnée n'a été lue pendant la dernière minute. Elle peut récupérer, selon la cause du problème, autrement elle ne fera juste rien, et par conséquent cessera d'enregistrer - ce qui est probablement mieux que d'inscrire à plusieurs reprises les dernières données qu'elle a reçu. Utiliser avec soin. Placez les autres options raisonnablement. Il s'avère que les stations La Crosse peuvent parfois cesser de répondre pendant plusieurs minutes si elles sont 'occupées' à faire autre chose, par exemple essai de se synchroniser au signal d'horloge. Vous devriez probablement éviter ce paramètre avec ces stations.

VP Type

 Applicable seulement aux stations Davis
Serial Port Série
Sélectionnez cette option, si votre station est une Vantage Pro branchée par un port Série
TCP/IP TCP/IP
Sélectionnez cette option, si votre Vantage Pro est branché via TCP/IP, vous devrez aussi fournir le port TCP et l'adresse IP.

Si votre station est branchée via USB, vous devrez installer le pilote de port Série virtuel et utiliser la station en mode Série. Voyez la FAQ Cumulus pour plus de déails.

VP TCP/IP Settings

 Applicable seulement aux stations Davis, lorsque branchées via TCP/IP
TCP Port Port TCP
Si votre station est une Vantage Pro branchée via TCP/IP, spécifiez ici le numéro du Port TCP à utiliser.
IP Address Adresse IP
Si votre Vantage Pro est branché via TCP/IP, spécifiez dans cette case l'adresse IP utilisée.
Discon period Période de déconnexion
Lorsque sélectionné, indique à Cumulus de se débrancher pendant le nombre de secondes spécifié, une fois par minute, à la minute pile (ou aussi près que possible) pour permettre à Weatherlink IP de se brancher au site Davis Weatherlink. Gardez ce chiffre aussi bas que possible afin de réduire au minimum le laps de temps que Cumulus passe déconnecté de la station. Entrez zéro pour désactiver, si vous n'utilisez pas le site Weatherlink.

Annual rainfall
YTD Amount Pluie, depuis le bébut de l'année
Vous pourriez avoir un total des précipitations (provenant d'une autre source) pour l'année en cours jusqu'à la date ou vous avez commencé à utiliser Cumulus. Entrez ce chiffre ici et Cumulus l'ajoutera à son propre calcul annuel de précipitations pour l'année spécifiée. Le chiffre que vous fournissez sera effectif au prochain démarrage de Cumulus.
Year Année
L'année à laquelle s'applique le total annuel à date.
Rainfall season start Début de la saison des pluies
Si vous voulez que votre total annuel de précipitations soit compté dès le début d'un mois en particulier (par exemple votre saison de précipitations pourrait être de août à juillet plutôt que les janvier à décembre), vous pouvez spécifier ici le mois de départ.

LOCATION:

 Notez que si vous ne fournissez pas votre lattitude et longitude (correctement), vos heures de levée et coucher du soleil seront erronnées.
Latitude | Entrez les valeurs appropriées pour la localisation de votre station.
Longitude | Entrez les valeurs appropriées pour la localisation de votre station.
Altitude | Placez à la valeur appropriée pour l'emplacement de votre station météorologique. Notez que Cumulus fait très peu avec ce chiffre autre que l'affichage. Par exemple, il ne fait aucune correction du niveau de la mer sur vos lectures de pression; vous devez vous assurer que vous avez configuré votre station jusqu'à la correction du niveau de la mer elle-même - toutes les stations ont cette fonction. À l'exception des stations WMR88/100/200 qui emploient le paramètre d'altitude pour calculer la 'pression d'altimètre' pour le téléchargement sur CWOP.
Name Permet un nom court pour votre localisation.

Exemple: Météo St-Ours.
Description Fournissez une description de votre localisation.
N.B. Si vous utilisez les pages HTML fournies pour votre site, cette description s'affichera après les mots ' Welcome to '

Exemple: St-Ours dans la vallée du Richelieu, au Québec.

UNITS:
Wind Speed
Pressure
Temperature
Rainfall 		Choisissez les unités de mesure dans lesquelles vous souhaitez que Cumulus enregistre et affiche les données

IMPORTANT: Vous devez choisir vos unités à la première utilisation de Cumulus et ne plus les modifier. Cumulus enregistre les données en utilisant ces paramètres. Si vous les modifiez par la suite, vos données seront incohérentes.

xAP Settings
enabled En fonction
Lorsque configuré, Cumulus enverra périodiquement des rapports météo xAP. Voir http://www.xapautomation.org/ pour plus de détails.
UID Identifiant UID
Entrez le code UID pour les messages xAP. Vous avez besoin de changer ce code seulement si vous exécutez plus d'une instance de Cumulus sur votre réseau.

Log roll over
9am Début du jour météo à 9h
Cochez cette case si vous souhaitez que l'historique quotidien débute à 09h00 chaque jour. Cumulus utilisera automatiquement 10h00 en été.
midnight Début du jour météo à minuit
Cochez cette case si vous souhaitez que L'historique quotidien débute à 00h00 chaque jour.
Data log interval Intervale historique
Choisissez l'intervalle auquel Cumulus doit ajouter un enregistrement dans le fichier d'historique. Il est recommandé de prendre le même interval que votre enregistreur de données (S'il en est équipé). Ceci est particulièrement important pour les stations Davis. Notez que Cumulus ne peut pas régler l'interval de l'enregistreur, pour ce faire vous devez utiliser la méthode requise selon votre station (ie. via la Console ou le logiciel fournis).Sur les stations Instromet, cependant, Cumulus fait le réglage d'intervalle de la station, à chaque démarrage.

Forecast:
Cumulus forecast Prévisions Cumulus
Sélectionnez cette option pour que Cumulus produise une prévision simple, si votre station n'en fournit pas, ou comme alternative à celle fournie par votre station. Notez que vous devriez considérer les prévisions comme étant 'pour votre plaisir seulement'. SVP, ne basez pas de décisions importantes sur ces prévisions et SVP ne vous plaignez pas à moi si elles sont erronées!
Update hourly Fréquence 1h
Si vous avez choisi d'avoir les prévisions de Cumulus, cette option actualise les prévisions seulement une fois l'heure (sur l'heure), pour éviter les fluctuations qui peuvent se produire quand les prévisions sont actualisés à chaque lecture des données de la station.
Pressure extremes Pression extrêmes
Entrez les pressions minimales et maximales attendues dans votre partie du monde. On s'attend à ce que les valeurs implicites soient convenables pour les latitudes britanniques et latitudes similaires, mais vous pouvez vouloir faire des expériences. Vous pouvez fournir les extrêmes en "mb" (millibar, qui est le même que hPa) ou en "in" (pouces de mercure), mais assurez-vous que les valeurs que vous fournissez concorde avec les unités de mesure que vous choisissez. Les unités que vous utilisez ici ne sont pas rattachées aux unités que vous utilisez pour la pression dans Cumulus; l'option est fournie simplement comme commodité.

Solar:
Sun threshold Le soleil brille?
Si vous avez un capteur solaire : Cumulus essaie de déterminer si le soleil brille en déterminant si la valeur de rayonnement solaire actuelle est au-dessus d'un certain pourcentage du maximum théorique actuel. La valeur que vous fournissez ici est utilisée pour définir ce pourcentage. La valeur par défaut est 75%. Vous pouvez regarder la valeur actuelle maximale théorique calculée «en planant» au-dessus de la valeur de rayonnement solaire sur l'écran principal de cumulus.
Sun minimum Minimum solaire
Cette option vous permet de spécifier une valeur de rayonnement solaire minimal devant être atteint pour que l'on puisse considérer que c'est ensoleillé. Notez que cette option ne remplace pas le calcul utilisant le maximum théorique actuel, il spécifie une condition supplémentaire à considérer. Cette option vous permet donc de déterminer les périodes de début et de fin du jour où le maximum théorique est très bas.
Transmission factor Facteur de transmission
Cumulus utilise la formule Ryan-Stolzenbach pour déterminer le rayonnement solaire maximum théorique actuel à votre localisation, au moment présent. Cette formule a un facteur pour tenir compte de la transmission de la radiation par l'atmosphère; le défaut est 0.8.
Use B/L Utiliser Blade-Larsen
Utilisez ce paramètre si vous disposez d'un enregistreur solaire Blake-Larsen, et souhaitez que Cumulus y puise les données d'heures d'ensoleillement du jour. Vous devez configurer le logiciel de Blake-Larsen pour mettre fichier SRsunshine.dat dans le dossier data de Cumulus pour que ce dernier puisse le lire.


Configuration: Display Settings

Paramêtres d'affichage :

(menu : CONFIGURATION - DISPLAY)

Cet écran vous permet de configurer l'apparence de Cumulus

General
Heading Entête
Permet de changer le titre de l'écran principal.
Minimize To Tray Minimiser
Sélectionner cette option fait apparaître Cumulus en tant qu'icône dans la zone de notification (system tray). L'icône clignotera si un record est établi, ou si une erreur se produit. Double cliquez sur l'icône pour restaurer la fenêtre principale (ou clic droit, et utilisez le menu contextuel)
Forecast centred Prévision centrée
Cette option permet de centrer les prévisions sur l'écran principal, plutôt qu'alignées à gauche
Display solar/extra data Affiche données solaire/supplémentaire
Sélectionnez cette option pour afficher les données solaire (ET, UV et le Rayonnement solaire) de votre Vantage Pro ou des stations Oregon (lux, radiation solaire et UV) sur l'écran principal (si fourni par la station), et/ou les capteurs supplémentaires dans le cas des stations Oregon.
Display cloud base Afficher le couvert nuageux
Sélectionnez cette option pour afficher le couvert nuageux calculé, sur l'écran principal. Le calcul est simple; 1000 pieds pour chaque différence de 4.5 degrés Fahrenheit entre la température et le point de rosée. Notez que cela donne simplement la hauteur théorique à laquelle les nuages de type Cumulus commenceraient à se former, l'air étant saturé
Display humidex instead of heat index Affiche humidex ou Indice de chaleur
Sélectionnez cette option pour afficher la valeur de l'Humidex calculé sur l'écran principal au lieu de l'Indice de Chaleur. Notez que Cumulus affiche des degrés C ou F pour l'Humidex, alors qu'à proprement parler c'est inutle. Disponible pour ceux qui utilisent Fahrenheit, mais préféreraient toujours voir Humidex affiché, où il pourrait être déconcertant de montrer la valeur non convertie.
Show current conditions box Affiche l'encadré des conditions actuelles
Cette option affiche l'encadré 'Current conditions' sur l'écran principal. Le contenu est entré manuellement et la balise web '<#currcond>' correspond à ce contenu, pour l'inclusion sur une page Web. Notez que la balise web prend toujours le contenu de l'encadré, sans tenir compte qu'il soit actuellement visible ou non.
Wind gauge animated Jauge des vents animée
Sélectionnez cette option pour "animer" la jauge des vents d'une position à la suivante à l'écran principal de Cumulus
Transparent gauge backgrounds Transparence des jauges
Cumulus crée des copies des trois jauges de vent de son écran principal, pour que celles-ci puissent être téléversées sur un site Internet. Les fonds carrés de ces jauges peuvent être de la même couleur que le fond de la fenêtre principale, ou en sélectionnant cette option, les images seront traitées pour rendre la couleur de base transparente.

Notez que si votre choix de couleur est tel que la couleur de base apparaît aussi dans les jauges elle-mêmes (dans un dégradé, par example), ces parties des jauges deviendront malheureusement et involontairement transparentes aussi. D'habitude cela pourrait apparaître comme une ligne diagonale traversant la jauge avec le fond de la page Web s'affichant au travers, ou d'autres parties des jauges ne s'affichant pas. Vous pouvez être en mesure de corriger cela en choisissant prudemment vos couleurs; juste le fait de changer légèrement pour une valeur RGB différente, serait suffisant.
Show FTP errors on error log window Affichage des erreurs FTP à l'écran
Si vous sélectionnez cette option, les erreurs de FTP seront notées à la fenêtre des historiques d'erreur et l'indicateur lumineux d'erreur rouge clignottera. Le fait de cliquer sur la lumière d'erreur affiche la fenêtre des historiques d'erreur.
Save main window position Enregistre la position de Cumulus
Si sélectionné, la position actuelle de la fenêtre principale sera enregistrée dans cumulus.ini à la fermeture de Cumulus. Au redémarrage de Cumulus, l'écran s'affichera à cette position.
Start minimised Démarrage minimisé
Si sélectionnée, Cumulus démarrera avec la fenêtre principale minimisée, dans la zone de notification ou dans la barre des tâche, selon le réglage de l'option 'Minimize to tray'.
Display Beaufort description Affiche la description de Beaufort
Si sélectionnée, la vitesse moyenne du vent sera affichée selon l'échelle de Beaufort et apparaîtra dans l'entête des vents sur l'écran principal. Sinon, il apparaîtra plutôt au passage de la souris dans le cadre des vents.
Display barometer trend text Affiche la tendance barométrique en texte
Si vous sélectionnez cette option, la description de la tendance baromètrique actuelle apparaîtra dans l'en-tête du cadre baromètre sur l'écran principal. Sinon, il apparaîtra plutôt au passage de la souris sur l'encadré baromètre.
Update display during logger download Met à jour l'affichage pendant la lecture de l'enregistreur de données
Si sélectionnée, l'écran sera mis à jour pendant le traitement des données de l'enregistreur de la station. Ceci augmente de temps de traitement des données. Ne pas sélectionner cette option rend le téléchargement plus rapide; ce qui peut être significatif s'il y a beaucoup de données à traiter.
Flash when record broken Clignotte lorsqu'un record est battu
Si sélectionnée (valeur par défaut), lorsqu'un records absolu est battu, Cumulus l'indiquera de plusieurs manières, incluant le clignottement du témoin 'New Record' (nouveau record) sur l'écran principal. Décocher cette option désactive la notification de tous nouveaux records.
Wind gauge animation factor Réglage de la vitesse d'animation de la jauge des vents
Cette option défini la vitesse d'animation de la jauge de vent. Les valeurs plus basses correspondent à une vitesse d'animation plus rapide. Faites attention de ne pas mettre l'animation trop lente, particulièrement avec les stations qui actualisent fréquemment (par ex. Davis) puisque l'animation ne se mettra pas à jour et utilisera un temps d'unité centrale significatif.
Wind gauge range Échelle de la jauge des vents
Cette option vous permet de choisir l'échelle initiale pour la jauge de vent. Quand la vitesse de vent arrive au-dessus de cette valeur, l'échelle passe à 2x la valeure, puis à 3x, etc. La valeur minimale que vous pouvez fournir est 5. Notez que des multiples de 5 sont à privilégier comme valeur, pour ne pas générer de bizarreries à l'écran.
Snow units Unité de mesure de la neige
Cette option vous permet d'entrer le texte qui apparaîtra pour la mesure de neige, dans l'historique météorologique. Notez qu'il n'y a aucune signification rattachée à ce texte et l'effet est purement cosmétique; il n'y a pas d'unité de mesure pour la neige, vous pouvez entrer le texte souhaité.
Station Model Modèle de station
Vous pouvez spécifier ici le modèle réel de votre station météorologique; ce qui apparaîtra sur les pages Web plutôt que la description générique par défaut. C'est utile particulièrement si vous avez une des nombreuses variantes de 'compatibles FineOffset', ou, par exemple, si vous avez une station Oregon Scientific avec numéro de modèle légèrement différent de ceux que Cumulus connait.

Graphs
Detailed Chart Period Période détaillée du graphe
Cette option vous permet de choisir l'intervalle pour les graphiques qui sont générés une fois par minute. Notez que si vous augmentez l'intervalle, les graphes ne seront pas redessinés tout de suite. Si vous diminuez l'intervalle, le changement sera effectif la prochaine fois qu'un point sera ajouté aux graphes concernés. Si vous voulez forcer un rafraichissement immédiat au nouvel intervalle, redémmarez Cumulus, mais notez que cela fera que les graphiques seront produits à partir des données des fichiers d'historique.
Daily Chart Period Graphs quotidiens
Cette option vous permet de choisir l'intervalle pour les graphiques qui sont générés une fois par jour. Notez que si vous changez l'intervalle, le graphe ne sera pas regénéré immédiatement. Si vous voulez forcer un rafraichissement immédiat au nouvel intervalle, redémmarez Cumulus.
Display 3D Affichage en 3D
Permet de choisir si les graphiques sont affichés en 2D ou en 3D
Plot latest gust Données 'Coup de vent'
Sur le graph du vent, Cumulus dessine normalement le plus fort coup de vent à partir des 10 dernières minutes. En activant cette option. Cumulus dessinera plutôt la dernière valeur de rafale 'gust' sur la station. L'effet de cette option dépend du type de station utilisée et de la manière dont elle produit la valeur de 'latest'. Notez que ce changement ne déclenche pas l'actualisation du graphique, il modifie seulement la méthode d'affichage à partir de ce moment.
Use South for Wind dir origin Utilise Sud pour l'origine du vent
Cette option Fait correspondre au Sud, l'axe du bas sur les graphs de direction du vent.
Show freezing line Affiche le point de congélation
Cette option affiche une ligne horizontale au point 0C/32F sur les graphiques de température.
Independent Graphs Window Fenêtre de Graphe indépendante
Rend la fenêtre de Graphes indépendante de la fenêtre principale, donc elle apparaît sur la barre des tâches. Exige à un redémarrage de Cumulus pour prendre effet.
Chart line width Largeur du trait
Cette option permet de définir l'épaisseur à utiliser pour les lignes de graphes.
Legend symbol width Largeur du trait des légendes
Cette option vous permet de définir l'épaisseur des lignes dans les légendes de graph. Notez : Pour voir la modification sur le graph, vous devrez choisir un graph différent
Wind Rose Points Points cardinaux sur la rose des vents
Cette option vous permet de définir combien de points seront affichés sur la rose des vents de l'écran principal Elle vous permet de choisir le nombre de points de boussole distincts qui sont dessinés (8 ou 16). Ce paramètre est un essai pour donner une plus grande précision aux stations Fine Offset qui semblent s'occuper peu des directions de vent 'intermédiaires'.
WMR928 extra channel captions Titre des capteurs WMR928 supplémentaires.
Cette option vous permet de 'nommer' sur l'écran principal, les données des canaux supplémentaires pour les stations WMR928.


Internet Settings

Configuration: Paramètres Internet

(Menu: CONFIGURATION - INTERNET)

(Consultez d'abord : Paramétrer son site web)

Cet écran vous permet de fournir les informations nécessaires sur votre Site Web, pour que Cumulus puisse téléverser les pages contenant vos statistiques météo. Vous pourriez devoir redémarrer Cumulus pour certains réglages prennent effet; entre autre, si vous changez de serveur ou si vous activez le mode FTP temps réel.

Onglet : Sites/Options

Host name Nom d'Hôte
Indiquez ici le nom (ou l'adresse IP) du serveur ftp auquel vous vous branchez lorsque vous envoyez des pages sur votre site web. Entrez seulement le nom d'hôte (HOST NAME) ou l'adresse IP (IP ADDRESS). Ne pas entrer d'Url - ne pas inclure "ftp://" ou "http://" ni rien de similaire.

Exemple: ftp.sanday.org.uk
FTP Port Numéro du port ftp
Cette option permet de spécifier le port à utiliser, pour vos connexions Ftp. Habituellement, vous n'avez pas à fournir ce paramètre, puisque le port 21 convient à la plupart des cas
Directory Votre nom de dossier distant
Ce paramètre vous permet d'indiquer le nom du repertoire qui contiendra vos pages météo sur le serveur ftp. Indiquez le chemin d'accès complet depuis le répertoire racine si nécessaire. Il est normalement plus sécuritaire et facile d'utiliser un chemin relatif, donc, sans la barre-oblique (/) de racine; éliminant ainsi le besoin d'être au courant de la structure du site. Laisser en blanc si vous utiliserez le répertoire 'par défaut' ou la racine du site, c'est-à-dire celui que votre hébergeur vous recommande d'utiliser quand vous vous branchez sur le serveur ftp. N'ajoutez pas de barre-oblique à la fin de l'adresse.

Exemple: indiquer mon_repertoire_meteo changerait de répertoire pour le téléversement sur le serveur Ftp, pour un dossier de premier niveau nommé mon_repertoire_meteo.
User name Nom d'utilisateur
C'est le nom d'utilisateur que vous employez habituellement pour vous brancher sur le serveur ftp de votre site web.
Password Mot de passe
C'est le mot de passé que vous utilisez quand vous vous branchez au serveur ftp de votre site web. Notez que Cumulus masque votre mot de passe avec des astérisques lorsque vous le saisissez, mais qu'il sera stocké dans le fichier .ini, en texte clair.
Forum URL Adresse du Forum
Ce paramêtre est optionnel. Vous pouvez l'utiliser pour indiquer l'URL d'un forum de discussion pour votre site web; Cumulus placera un lien sur la page web générée. Si vous le souhaitez, vous pouvez utiliser le forum par défaut, qui pointe sur le forum de sandaysoft.com. Si vous laissez ce champ à vide, Cumulus ne générera pas de lien vers un forum.
Webcam URL Url de votre caméra Web
C'est un paramètre optionnel que vous pouvez utiliser pour fournir un lien vers une Webcam, si vous en avez une. Cumulus placera un lien sur la page web générée. Si vous le souhaitez, vous pouvez utiliser la webcam par défaut, qui est la webcam du site sanday.org.uk. Si vous laissez ce champ à blanc, Cumulus ne générera pas de lien vers une webcam.

Web settings
Auto update Mise à jour automatique
Si vous sélectionnez cette option, Cumulus enverra automatiquement vos pages web sur votre site à intervalle régulier (spécifié dans 'Update Interval'). Si vous ne cochez pas cette option, vous devrez téléverser manuellement sur votre site avec l'option 'Web update' du menu 'File'.
Use Active FTP Mode FTP Mode actif
Si vous sélectionnez cette option, Cumulus utilisera le mode FTP 'actif' au lieu du mode 'passif' par défaut. Sélectionnez cette option seulement si vous avez des problèmes de téléversement FTP.
Use FTP rename Renommer avant la copie
Si vous sélectionnez cette option, Cumulus téléversera les fichiers avec un nom temporaire, puis les renommera avec le nom d'origine. Il est recommandé d'utiliser cette option si possible, mais notez que certains hébergeurs ne la supporte pas.
Delete before upload Effacer avant de copier
Si vous activez cette option, Cumulus effacera le fichier sur le serveur avant de téléverser une nouvelle version. Cette option est prévu pour les serveurs ftp qui ne permettent pas le remplacement de fichiers. Normalement vous n'avez pas besoin de l'utiliser - ne l'utilisez pas à moins que vous soyez certains que vous en avez besoin. Auquel cas, assurez-vous de ne pas utiliser cette option et le 'FTP rename' en même temps.
Interval Intervalle des mise à jour
Temps entre deux mises à jour des pages web (en minutes).Si vous spécifiez une période qui est un facteur de 60, les téléchargements seront synchronisés à l'horloge, c.-à-d. ils se produiront sur l'heure à chaque N minutes après l'heure.
Enable Realtime Activer le mode temps réel
Si vous sélectionnez cette option, Cumulus demarrera une minuterie à l'intervalle spécifié par l'intervalle en temps réel 'Realtime Interval' (voir ci-dessous). À chaque expiration du délais, Cumulus générera un fichier realtime.txt. Ce fichier contient divers paramètres météo, et est utilisé par les jauges de vent en temps réel (CumulusRealtime.swf) inclues dans le pages Web 'gauges' fournies par Cumulus et par l'application web autonome Cumulus Realtime Silverlight. Si vous ne cochez pas cette option, mais avez sélectionné 'auto update' (et configuré un intervalle convenable), Cumulus continuera de générer le fichier realtime.txt à l'intervalle indiqué (pas à l'intervalle 'Realtime Interval') pour que vous puissiez le spécifier comme un fichier supplémentaire à téléverser pendant les opérations normales, ou pour l'utiliser à d'autre fin sur votre ordinateur.
Enable Realtime FTP Activer le mode FTP en temps réel
Lorsque sélectionné, Cumulus établi une connexion FTP à votre site Internet, pour que le fichier realtime.txt et autre fichier que vous pourriez spécifier, puissent être téléversés quand le traitement en temps réel survient. Le paramètre 'Enable Realtime' doit être activé pour que cette option ait un effet. Il est important de ne pas cocher cette option si vous n'utilisez pas FTP.
Realtime.txt FTP Activer le fichier realtime.txt
en activant cette option, Cumulus téléversera le fichier realtime.txt sur votre site Internet pendant le traitement en temps réel. Les paramètres 'Enable Realtime' et 'Enable Realtime FTP' doivent être activés toutes deux pour que cette option ait un effet. Il est important de ne pas cocher cette option si vous n'utilisez pas FTP.
Realtime Interval Interval temps réel
Temps entre deux traitements du fichier realtime.txt (en secondes). Le défaut est 30 secondes. Vous pouvez vouloir le régler selon l'intervalle de mise à jour de votre station. Par exemple, la mise à jour de stations de Fine Offset se fait toutes les 48 secondes, donc le 30 secondes de délais par défaut est sans doute raisonnable pour celles-ci, mais la mise à jour des stations Davis se fait environ toutes les trois secondes, donc vous pouvez vouloir réduire l'intervalle de temps réel en conséquence. Mais notez que bien que la taille du fichier 'realtime.txt' soit minime (actuellement environ 250 octets), en le téléversant très souvent, une bande passante significative sera consomée à long terme, donc vous devriez vérifier avec votre fournisseur Internet et/ou votre hébergeur web pour voir si votre forfait compte des limites de bande passante.

APRS/CWOP Settings
Enabled Activer
Cochez cette case pour autoriser Cumulus à téléverser des données vers un réseau CWOP/APRS selon l'intervalle spécifié ci-dessous
ID Identité
Votre identifiant APRS
Pass Mot de passe
Mot de passe APRS, si vous en avez un. Normalement, il est utilisé seulement par les radio-amateurs licenciés, les autres utilisateurs peuvent laisser -1.
Serveur Serveur
serveur APRS à utiliser.
Port Numéro du port
Numéro du port à utiliser sur le serveur APRS.
Interval Interval entre les envois
Intervalle de temps en minutes entre deux téléversements vers le serveur APRS. Si vous spécifiez une période qui est un facteur de 60, les télécharversements seront synchronisés sur l'horloge, c.-à-d. ils se produiront sur l'heure et chaque N des minutes après l'heure.
Include Solar rad Inclure les données solaires
Inclu les observations de radiation solaire dans les données.

Weather Underground
Enabled Activer
Cochez cette case pour autoriser Cumulus à téléverser des données vers Weather Underground selon l'intervalle spécifié ci-dessous.
Include UV Inclure les données UV
Inclu les observations UV avec les données à envoyer
Include Solar rad Inclure donnes solaire
Inclu les observations de radiation solaire dans les données.
Rapid fire Mode Rapid Fire
Cette option active le mode 'Rapid fire'. Vous devez aussi cocher 'Enabled' ci-dessus. Les mise à jour 'Rapid fire' s'exécutent aux 5 secondes.
Send average wind Envoi moyenne du vent
Cochez pour envoyer la vitesse moyenne et la directon du vent, plutôt que la vitesse instantanée de la rafale de vent, et la direction.
Catch Up Envois en cours
Une fois configuré, au démarrage Cumulus essayera d'envoyer des données qu'il vient juste de télécharger de l'enregistreur de la station, sur Weather Underground, évitant de ce fait des trous dans vos données de WU pour la période où Cumulus ne fonctionnait pas. Il envoie une mise à jour par entrée d'enregistreur téléchargée, indépendamment de votre intervalle de mise à jour configuré. Notez que s'il ne peut pas contacter WU pour une raison quelconque, ces mises à jour ne seront pas réessayées et seront ainsi perdues. Notez également que si vous fermez Cumulus tandis qu'il téléverse les données, la mise à jour sera avorté et toutes données non-envoyées seront perdues. La lumière 'catch up' sur l'écran principal clignotera tandis que l'envoi est en cours.
Station ID Identificateur de station
Votre identifiant Weather Underground (Note: pas votre nom d'usager).
Password Mot de passe
Votre mot de passe Weather Underground
Interval Intervalle
Intervalle de temps en minutes entre deux téléversements. Weather Underground recommande un intervalle de 5 ou 15 minutes. Si vous spécifiez une période qui est un facteur de 60, les téléversements seront synchronisés à l'horloge, c.-à-d. ils se produiront sur l'heure et chaque N des minutes après l'heure. Lorsque 'Rapide fire' est activé, ce paramètre n'a aucun effet; toutes les mise à jour seront faites en mode 'Rapid Fire'.

PWS Weather
Enabled Activer
Sélectionnez cette option pour autoriser Cumulus à téléverser des données vers PWS Weather / WeatherForYou / HAMweather selon l'intervalle spécifié ci-dessous.
Include UV Inclu données UV
Inclu les observations UV avec les données à envoyer
Include Solar rad Inclu les données solaires
Inclu les observations de radiation solaire dans les données.
Catch Up Envoi en cours
Lorsque configuré, au démarrage Cumulus essayera d'envoyer des données qu'il vient juste de télécharger de l'enregistreur de la station, sur PWS Weather, évitant de ce fait des trous dans vos données de PWS pour la période où Cumulus ne fonctionnait pas. Il envoie une mise à jour par entrée d'enregistreur téléchargée, indépendamment de votre intervalle de mise à jour configuré. Notez que s'il ne peut pas contacter PWS pour une raison quelconque, ces mises à jour ne seront pas réessayées et seront ainsi perdues. Notez également que si vous fermez Cumulus tandis qu'il téléverse les données, la mise à jour sera avorté et toutes données pas déjà envoyées seront perdues. La lumière 'catch up' sur l'écran principal clignotera tandis que l'envoi est en cours. NOTE : Au moment d'écrire ces lignes (fin 2011) PWS Weather mentionne qu'ils ne soutiennent pas le 'rattrapage' des téléversements
Station ID Identifiant de Station
Votre identifiant PWS Weather (Note: pas votre nom d'usager)
Password Mot de passe
Votre mot de passe PWS Weather.
Interval Intervalle
Intervalle de temps en minutes entre deux téléversements. PWS Weather suggère un intervale de 30 minutes. Si vous spécifiez une période qui est un facteur de 60, les téléversements seront synchronisés à l'horloge, c.-à-d. ils se produiront sur l'heure et chaque N des minutes après l'heure.

Weatherbug
Enabled Activer
Cochez cette option pour permettre à Cumulus de téléverser des données selon l'intervalle mentionné ci-dessous
Include UV Inclure données UV
Inclu les observations UV avec les données à envoyer
Include Solar rad Inclure rayonnement solaire
Inclu les observations de radiation solaire dans les données.
Catch Up Envoi en cours
Lorsque configuré, au démarrage Cumulus essayera d'envoyer des données qu'il vient juste téléchargé de l'enregistreur de la station, sur Weatherbug, évitant de ce fait des trous dans vos données de Weatherbug pour la période où Cumulus ne fonctionnait pas. Il envoie une mise à jour par entrée d'enregistreur téléchargée, indépendamment de votre intervalle de mise à jour configuré. Notez que s'il ne peut pas contacter Weatherbug pour une raison quelconque, ces mises à jour ne seront pas réessayées et seront ainsi perdues. Notez également que si vous fermez Cumulus tandis qu'il téléverse les données, la mise à jour sera avorté et toutes données pas déjà envoyées seront perdues. La lumière 'catch up' sur l'écran principal clignotera tandis que l'envoi est en cours.
Publisher ID Identifiant
Votre identifiant Weatherbug
Numéro de station Identifiant de Station
Votre numéro de station Weatherbug
Password Mot de passe
Votre mot de passe Weatherbug
Interval Intervalle
Temps en minutes entre les téléversements. Si vous spécifiez une période qui est un facteur de 60, les téléchargements seront synchronisés à l'horloge, c.-à-d. ils se produiront sur l'heure et chaque N des minutes après l'heure.

WOW
Enabled Activer
Cochez cette option pour permettre à Cumulus de téléverser des données sur le site d'observations météo UK Met Office, selon l'intervalle mentionné ci-dessous
Include UV Inclure données UV
Inclu les observations UV avec les données à envoyer
Include Solar rad Inclure données solaires
Inclu les observations de radiation solaire dans les données.
Catch Up Envoi en cours
Lorsque configuré, au démarrage Cumulus essayera d'envoyer des données qu'il vient juste téléchargé de l'enregistreur de la station, sur WOW, évitant de ce fait des trous dans vos données de WOW pour la période où Cumulus ne fonctionnait pas. Il envoie une mise à jour par entrée d'enregistreur téléchargée, indépendamment de votre intervalle de mise à jour configuré. Notez que s'il ne peut pas contacter WOW pour une raison quelconque, ces mises à jour ne seront pas réessayées et seront ainsi perdues.Notez également que si vous fermez Cumulus tandis qu'il téléverse les données, la mise à jour sera avorté et toutes données pas déjà envoyées seront perdues. La lumière 'catch up' sur l'écran principal clignotera tandis que l'envoi est en cours.
Site ID Identifiant de station
Votre identifiant de site WOW, tel qu'alloué par WOW lorsque vous avez créé votre site.
PIN Clef d'accès
Votre numéro PIN à six chiffres, tel que fourni à WOW lorsque vous avez créé votre site.
Interval Intervalle
Temps en minutes entre les téléversements. Si vous spécifiez une période qui est un facteur de 60, les téléchargements seront synchronisés sur l'horloge, c.-à-d. ils se produiront sur l'heure et chaque N des minutes après l'heure.

Twitter
Enabled Activer
Cochez cette option pour permettre à Cumulus de téléverser des rapports sur Twitter (http: // www.twitter.com) à l'intervalle spécifié par 'Interval' ci-dessous. Si vous voulez personnaliser le message twitter, créez un fichier twitter.txt dans le dossier d'installation de Cumulus pour contenir votre message. Vous pouvez utiliser les Balises Web standard.
Send location Inclu la localisation
Lorsque sélectionné, Cumulus envoie votre latitude et longitude avec votre 'tweet'. Si vous voulez que Twitter affiche votre localisation avec chaque 'tweet', vous aurez besoin d'activer "Add a location to your tweets" dans vos paramètres de compte de Twitter.
User Identifiant
Votre nom d'usager Twitter
Password Mot de passe
Votre mot de passe Twitter
Interval Intervalle
Intervalle de temps en minutes entre deux téléversements sur Twitter. Si vous spécifiez une période qui est un facteur de 60, les téléchargements seront synchronisés sur l'horloge, c.-à-d. ils se produiront sur l'heure et chaque N minutes après l'heure.

Graphs
Resize Redimensionner
Sélectionnez cette option pour changer les dimensions des grandes images de graphe générées pour téléversement sur votre site Internet. Spécifiez la hauteur et la largeur voulue dans les boîtes correspondantes. Notez que les images sont simplement adaptées à la nouvelle taille; il y aura une perte de qualité.
Height Hauteur
Entrez la hauteur requise pour le graphique, en pixel
Width Largeur
Entrez la largeur requise pour le graphique, en pixel

External Programs
Program Programme à exécuter
Le nom (en incluant le chemin) d'un programme de ligne de commande a être exécuté à l'intervalle de mise à jour web 'normal', après que tout traitement a été exécuté. La boîte 'params' correspondante peut être utilisée pour spécifier n'importe quel paramètre à passer à la commande.
Realtime Program Programmes en temps réel
Le nom (en incluant le chemin) d'un programme de ligne de commande a être exécuté à l'intervalle de mise à jour 'temps réel', après que tout traitement a été exécuté. La boîte 'params' correspondante peut être utilisée pour spécifier n'importe quel paramètre à passer à la commande.
Daily Quotidiennement
Le nom (en incluant le chemin) d'un programme de ligne de commande a être exécuté une fois par jour, après que tout traitement quotidien ait été effectué. La boîte 'params' correspondante peut être utilisée pour spécifier n'importe quel paramètre à passer à la commande.

Onglet : Files
Include Standard Files Inclure gabarit standard
Si cette case est cochée, les fichiers web standards fournis avec Cumulus seront créés et téléversés à chaque mise à jour web. Si non cochée, les fichiers seront traités et les pages Web seront créées, mais ne seront pas téléversées.
Include Standard Images Inclu les images standard
Si cette case est cochée, les images standards générées par Cumulus (graphes, etc) seront téléversées à chaque mise à jour web. Si non cochée, les images seront créées, mais ne seront pas téléversées.
Solar Inclu graphe solaire
Si cette case est cochée, le graphe solaire généré par Cumulus sera téléversé (ou copié, si l'option est sélectionnée) à chaque mise à jour web. Si non cochée, l'image sera créé, mais ne sera pas téléversée ou copiée.
UV Inclu graphe UV
Si cette case est cochée, le graphe UV généré par Cumulus sera téléversé (ou copié, si l'option est sélectionnée) à chaque mise à jour web. Si non cochée, l'image sera créée, mais ne sera pas téléversée ou copiée.
Sunshine Inclure graphe d'ensoleillement
Si cette case est cochée, le graphe d'heures d'ensoleillement généré par Cumulus sera téléversé (ou copié, si l'option est sélectionnée) à chaque mise à jour web. Si non cochée, l'image sera créée, mais ne sera pas téléversée ou copiée.
Local Filenames Nom de fichier sur le Pc
Cette colonne vous permet de spécifier jusqu'à 10 fichiers sur votre système qui seront téléchargés vers votre site web à chaque mise à jour de votre site. Cliquer sur le bouton 'Browse...' pour ouvrir une boite de dialogue standard de sélection de fichiers. Ne pas inclure les fichiers gabarit 'standard' ici, indiquez-les par les deux cases ci-dessus. Vous pouvez spécifier la chaine <currentlogfile> ici, et cumulus emploiera le fichier d'historique mensuel actuel
Binary Mode binaire
Cette colonne vous permet de préciser si le fichier est Binaire (images) ou non (par exemple des fichiers HTML) .
Remote Filenames Nom de fichier distant
Cette colonne vous permet de spécifier le nom de chacun des fichiers sur le site web. Vous devrez spécifier le chemin complet, en partant du point où vous êtes lorsque vous vous connectez au serveur FTP de votre site web. Si la case 'FTP?' n'est pas cochée (voir ci-dessous), Cumulus interprétera ce nom comme un dossier de destination local dans lequel le fichier doit être copié.

Vous pouvez employer la commande <currentlogfile> ici, et cumulus substituera le nom du fichier d'historique actuel (par exemple Nov13log.txt). Vous avez toujours besoin de spécifier un chemin complet, finissant avec le <currentlogfile> par exemple html_files/weather/<currentlogfile>
Process? Traitement des Balises
Cette colonne vous permet de spécifier les fichiers qui devront être traités par le 'convertisseur de balise' de Cumulus de la même manière que les pages standard. Ceci vous permet de créer vos propres pages web, dans lesquelles Cumulus insérera les divers paramètres météo. Consultez la section Balises Cumulus" pour obtenir la liste des balises que vous pouvez utiliser. Cumulus créera un fichier temporaire pour contenir la version générée de votre fichier, puis le téléversera. Ne pas utiliser cette option si vos fichiers ne contiennes pas de balises cumulus ou s'ils sont en format binaire.
Realtime? Temps réel
Cette colonne vous permet de spécifier quels fichiers seront téléversés, selon le mode Realtime (temps réel) ou en mode Normal. Si vous choisissez cette option pour un fichier, vous devez également choisir le mode Realtime (sur l'onglet 'Files/Options'). Si vous choisissez aussi l'option 'Ftp' pour un fichier désigné 'Realtime', vous aurez aussi besoin de sélectionner l'option 'realtime FTP'.
FTP Envoi Web
Cette colonne vous permet de spécifier si le fichier sera téléversé par FTP, ou simplement copié dans un dossier sur votre ordinateur. Dans ce dernier cas, vous devrez entrer le nom du fichier de destination dans la case 'Remote Filename'.
Copy images to folder Copier les images dans un dossier
Cette option vous permet de spécifier un dossier dans lequel les fichiers images standard seront copiés à chaque intervalle de mise à jour Web, en mode 'normal', ou 'temps réel', selon si la case 'Realtime ?' est cochée. Si vous sélectionnez la case 'Realtime ?', vous aurez aussi besoin de choisir l'option 'Enable Realtime' (sur l'onglet Sites/Options). Notez que ce paramètre copie les fichiers localement; il n'est donc pas nécessaire si vous utilisez ftp.

Notez: bien que l'affichage soit limité à dix fichiers supplémentaires, vous pouvez actuellement configurer jusqu'à 99 fichiers en éditant le fichier cumulus.ini (lorsque Cumulus est arrêté). Ajoutez des ensembles de lignes ainsi (un jeu par fichier) à la section [FTP site] :

ExtraLocalXX= (chemin fichier local + nom)
ExtraRemoteXX= (chemin du fichier distant + nom)
ExtraProcessXX= (0 = ne contien pas de balises, 1 = Le fichier contien des balises cumulus à traiter)
ExtraBinaryXX= (0 = fichier ascii, 1 = fichier binaire)
ExtraRealtimeXX= (0 = téléversement à intervale 'normal', 1 = Téléversement temps réel)
ExtraFTPXX= (0 = copier, 1 = ftp)

Remplacez XX par un nombre entre 10 et 99 (les fichiers existant sont de 0 à 9). Vérifiez dans votre fichier cumulus.ini actuel si n'êtes pas sûr du contenu à ajouter.

Onglet : Proxies
Si vous utilisez un serveur proxy pour l'accès HTTP, entrez les détails de votre serveur proxy ici. Vous devez ajouter au minimum le nom du serveur proxy ou son adresse IP et le port. Le nom d'utilisateur et le mot de passe peuvent être nécessaires selon la façon dont votre serveur proxy est configuré. Je suppose que puisque vous utilisez un proxy, vous savez les détails que vous avez besoin de fournir!


Calibration

(Menu : CONFIGURATION - CALIBRATION)

Cet écran peut être affiché en sélectionnant Calibration dans le menu Configuration. Cet écran permet de définir des valeurs pour corriger des erreurs dans les données transmises par les capteurs de la station météo; si vous avez une valeur de référence plus précise, ou si vous voulez compenser des erreurs dues à la position de vos capteurs (par exemple la hauteur de l'anémomètre). Les valeurs de la section Offsets sont ajoutées ou soustraites (si négatives) aux données transmises, et les valeurs de la section Multipliers sont utilisées pour multiplier les données transmises.

Une valeur de compensation (offset) égal à zero n'a aucun effet, et un multiplicateur égal à 1 non plus. Un multiplicateur égal à 0,75 réduit la valeur obtenue de 25% et un multiplicateur de 1.25 augmentera la valeur de la donnée de 25%, etc.

Si un item présente une valeur de compensation et un multiplicateur, le multiplicateur est appliqué en premier, puis la compensation

Notez que si vous spécifiez des valeurs de compensation pour le vent ou la temperature, vous souhaiterez probablement spécifier l'option 'calculate wind chill' dans les paramètres configuration de la station, pour que Cumulus puisse appliquer cette valeur au refroidissement éolien (Wind Chill). Notez aussi que vous devriez essayer d'éviter d'utiliser les réglages de calibration de la pression; il est beaucoup mieux de calibrer votre station correctement pour la pression au 'niveau de la mer' (sea level pressure) - toutes les stations vous permettent de le faire.

Le paramètre 'Wet Blub' s'applique seulement aux stations qui fournissent directement une lecture du thermomètre mouillé, c-à-d les stations Instromet.

La section 'Spike removal' (normalisation des pointes) vous permet de spécifier les différences maximales entre deux lectures successives que vous voulez permettre, particulièrement pour les stations FineOffset et La Crosse. Si une lecture diffère de la lecture précédente de la valeur que vous spécifiez, ou plus, elle sera ignorée. Soyez prudents dans votre choix de valeurs; si la différence est vraie, (c'est-à-dire pas 'une pointe') et excède votre valeur fournie, donc cette lecture sera coincée à la valeur précédente jusqu'à ce qu'une nouvelle lecture revienne en dessous du maximum spécifié. Chaque fois qu'une pointe est normalisée, une écriture est faite dans le fichier 'diags' courant. Cocher la case 'Log to Error Log' (Écrire dans le journal des erreurs) provoquera l'ajout de cette erreur à l'écran d'affichage des erreurs et le témoin 'Error' clignottera. Notez que parfois Cumulus détecte des données invalides pour d'autres raisons, celles-ci sont enregistrées de la même manière.

Le paramètre de taux de pluie maximum (Max Rain Rate) s'applique seulement lorsque Cumulus calcul ce taux lui-même (pour les stations 'compatibles FineOffset' et LaCrosse). Pour ce paramètre et le paramètre de pluie maximale en une heure (Max Hourly Rain), si la lecture dépasse la valeur définie, elle sera ignorée, c'est-à-dire la précédente valeur calculée valide continuera de s'appliquer. Le paramètre 'Max Hourly Rain' s'applique à tous les types de station.

Notez que les valeurs de normalisation des pointes (Spike Removal) doivent être fournies dans les unités 'natives' de la station, telle qu'affichées à l'écran. La valeur de rafale (Wind Gust) n'a aucun effet sur les stations La Crosse, puisqu'elle fournit seulement une valeur de vent - la 'correction de pointe' est appliquée au niveau de la station, à la différence des valeur de compensation et des multiplicateurs qui sont appliqués à un niveau 'commun'; utilisez seulement la valeur de 'Wind Speed' (Vitesse du vent).

La normalisation des pointes n'est en fonction que sur les données en direct et non sur les données lues au démarrage.


Personalisation et Internationalisation

Dans le dossier ou vous avez installé Cumulus, vous trouverez un fichier nommé 'samplestrings.ini'. Prenez une copie de ce fichier, laissez-le dans le dossier d'installation de Cumulus, et nommez-le 'strings.ini'. Le fichier contient plusieurs phrases utilisées à divers endroit dans Cumulus, ex. pour les prévisions.

forecast23=Precipitation at frequent intervals

Éditez les phrases selon vos besoins,par exemple:

forecast23=Il pleut encore!

Lorsque vous démarrerez Cumulus, il utilisera les phrases que vous avez spécifiées au lieu des phrases par défaut. Plus de phrases personnalisables seront ajoutées au fil du temps.


NOAA Setup

La fenêtre 'NOAA Setup' (Configuration NOAA)

(Menu: CONFIGURATION - NOAA Setup)

Cette fenêtre peut être affichée en sélectionnant 'NOAA Setup' dans le menu 'Configuration'.

Site name/City/State Nom du site/Ville/État
Description/Localisation de votre site.
Time format Format horaire
Utiliser le format 12 ou 24 heures dans les rapports.
Monthly filename format Nom du fichier mensuel
Cette option permet de spécifier le format du nom du fichier utilisé pour les rapports mensuels, utilisant des caractères de formattage de date (voir le paramètre de format des Balises Web). Notez que tous les caractères qui ne sont pas des caractères de format de date devraient être entre guillemets, par exemple le format par défaut est "NOAAMO"mmyy".txt"
Yearly filename format Nom du fichier annuel
Cette option permet de spécifier le format du nom du fichier utilisé pour les rapports annuels, utilisant des caractères de formattage de date (voir le paramètre de format des Balises Web). Notez que tous les caractères qui ne sont pas des caractères de format de date devraient être entre guillemets, par exemple le format par défaut est "NOAAYR"yyyy".txt"
Use UTF-8 Utiliser UTF-8
Si défini, Cumulus va utiliser l'encodage UTF-8 lors de l'enregistrement des rapports. Ceci peut être utile si vous avez des caractères non ANSI dans votre nom de station, etc. et que vous voulez intégrer le fichier dans une page web. Vous pouvez également avoir besoin de changer l'encodage de votre page web en spécifiant charset=UTF-8.
Auto save after daily reset Sauvegarde automatique quotidienne
Lorsque cette option est activée, Cumulus fait sa routine de fin de journée, puis crée automatiquement des rapports de style NOAA pour le mois et l'année correspondant au jour qui vient de se terminer.
Auto FTP after auto-save Envoi FTP automatique
Si activée, lorsque Cumulus fait son premier téléversement FTP de fin de journée, il envoi aussi le rapport autogénéré de style NOAA pour les rapports mensuels et annuel. Notez que vous devez déjà avoir configuré le FTP régulier (non temps-réel).
FTP directory Répertoire FTP
Le répertoire FTP dans lequel Cumulus essayera de téléverser les derniers rapports de style NOAA. Vous devez donner le chemin complet à partir du dossier de login, et ne fournissez pas de 'barre oblique' de fin. Notez que le répertoire doit réellement exister sur le serveur.
Heating/Cooling threshold Seuils chauffage/climatisation
Les températures qui doivent être employées pour calculer les degrés-jours de refroidissement et de chauffage. Notez que Cumulus comporte deux méthodes différentes pour determiner les calculs de degrés-jours. Depuis la version où ce calcul a été indroduit, le calcul est basé de minute en minute, et les totaux finalement stockés dans le fichier dayfile.txt à la fin du jour. Il n'est donc pas possible d'affecter ces totaux restrospectively en changeant les seuils. Pour les données qui ont été enregistrées avant que la fonction ne soit introduite, il n'y a évidemment aucune valeur de degré-jour dans le fichier dayfile.txt. Les valeurs pour le rapport NOAA sont alors calculées simplement en comparant la température quotidienne moyenne aux réglages actuels de seuil, alors dans ce cas n'importe quel changement de seuil s'applique rétrospectivement pour ces jours. Notez que le rapport lui-même affichera toujours la valeur du seuil lorsque le rapport a été produit. Vous devriez donc choisir soigneusement vos paramètres de seuil et ne pas en changer.
Max/min temp comparisons Comparaison des températures min/max
La valeur utilisée dans les rapports pour le calcul du nombre de jours de températures maximum/minimum au-dessus/au-dessous des températures définies. Notez qu'il est intentionnel qu'une des comparaisons 'maximale' soit 'plus grande' et une soit 'moins que'.
Rain comparisons Comparaison pluie
Les valeurs utilisées dans les rapports pour le calcul du nombre de jours de pluie soit plus élevé que (ou égale) au nombre spécifié.
Normal mean temp/Normal precipitation Précipitations et température normales/moyennes
Si vous avez accès aux moyennes à long terme pour les températures moyennes mensuelles et aux précipitations pour votre emplacement, vous pouvez les entrer ici. Elles seront alors employées dans la colonne 'departure from norm' des rapports annuels.


Configuration du RG-11

RG-11 Settings

(Menu: CONFIGURATION - RG-11)

Cette fenêtre peut être affichée en sélectionnant RG-11 dans le menu Configuration, L'écran permet de configurer des paramètres pour jusqu'à deux sondes de pluie de type Hydreon RG-11, reliées à votre PC par l'intermédiaire d'un port Série. Le port peut être un 'vrai' port Série, ou un adaptateur USB/Série. Le relais 'normalement ouverts' du capteur de pluie devraient être relié aux broches DSR et DTR du port Série , ou aux broches RTS et CTS. Vous pouvez relier deux sondes RG-11 au même port, une à DTS/DTR et une à RTS/CTS.

Vous pouvez utiliser un capteur RG-11 avec Cumulus, dans un de ces deux modes:

Dans le mode 'il pleut', la sonde indique s'il pleut ou non actuellement. Cumulus transmet cette information par l'intermédiaire d'un indicateur dans le coin inférieur droit de l'écran principal, dans le cadre de pluie. Il est gris quand il ne pleut pas, et rouge quand il pleut. La balise web <#IsRaining> fournit la même information pour l'utilisation par un site web, donnant '0' lorsqu'il ne pleut pas, et '1' lors de pluie.

En mode 'Tipping Bucket' (auget basculeur), la sonde agit comme un pluviomètre à auget basculeur, avec une taille de bout configurée sur le dispositif. Vous devez fournir la taille de bout à Cumulus (dans l'unité de mesure employée normalement par Cumulus pour des précipitations), et il montrera alors les totaux d'aujourd'hui et d'hier sur l'écran principal, à côté des valeurs équivalentes du pluviomètre de la station. Des Balises Web sont également fournies, voir la section de l'aide sur les Balises Web pour plus de détails.

Il s'avère qu'une fausse lecture puisse être enregistrée lorsque Cumulus ouvre le port Série. Vous pouvez placer 'Ignore first' si celà se produit, et Cumulus ignorera la première indication du 'Tip'

Notez que vous devez vous assurer que vos paramètres sont cohérents; vous pouvez seulement avoir un dispositif réglé au mode 'auget basculeur' et un en mode 'il pleut'. Cumulus n'en fait pas la validation.


Démarrage

Cumulus - premier contact

L'écran principal en détail

L'écran principal de Cumulus se divise en 9 zones distinct:

Écran principal de Cumulus

Voici une description détaillée de ces zones:

1 - La zone d'entête:

- Le nom de votre station (My Weather). Ce titre sera utilisé comme nom de votre site web et sera utilisé aussi dans vos pages web.

- La lune en image et la phase lunaire en cours

- Les éphémérides du jour:

  • Sun rises - Levé du soleil
  • Sun sets - Couché du soleil
  • Dawn - Aube
  • Dusk - Crépuscule
  • Day lenght - Durée du jour
  • Daylight - Heures de clarté
  • Tomorrow - Différence de longueur du jour pour demain
  • Moon rises - Levée de lune
  • Moon sets - Couché de lune

La date et l'heure se retrouvent à l'extrême droite de l'entête.

- Forecast - La prévision météo actuelle termine la zone d'entête.

2 - Outdoor - La zone des données extérieures (Outdoor)

  • Temp - Température actuelle
  • Trend - Tendance (augmetation ou diminution) dans la dernière heure
  • Avg Temp - Température moyenne lors des dernières lectures.
  • Wind Chill - Refroidissement éolien en degré
  • Heat Index - Indice de chaleur (semblable à l'humidex canadien)
  • Dewpoint - Point de rosée
  • Rel Hum - Humidité relative
  • Apparent - Température apparente

3 - Wind - La zone des Vents

La partie supérieur de cet encadré, l'entête, présente en plus du mot "Wind" (Vent), la vitesse du vent exprimée sur l'échelle de Beaufort. Cet indice s'échelonne de F0 - Calme à F12 - Ouragan.

  • Latest - La dernière lecture de la vitesse du vent
  • Bearing - La direction du vent exprimée en degré et en points cardinaux.
  • Gust - La vitesse de la dernière rafale de vent
  • Average - La vitesse moyenne du vent au cours de la dernière période de 10 minutes.
  • Avg Dir - Direction moyenne du vent aur une période de 10 minutes.
  • Wind Run - Parcours du vent (distance parcouru par le vent selon la vitesse).

4 - Barometer - La zone du baromètre

L'entête de cet encadré affiche l'évolution de la pression sous forme de texte (ex: Hausse lente).

  • Pressure - La pression actuelle.
  • Trend - Tendance de la pression dans la dernière heure.

5 - Rainfall - La zone de pluie

  • Rate - La quantité maximum de pluie recue.
  • Last Hour - La quantité de pluie recue dans la dernière heure
  • Today - La quantité de pluie recue dans la journée.
  • Last 24 hrs - Quantité de pluie recue pour les dernières 24 heures.
  • Yesterday - Quantité de pluie recue le jour précédent.
  • This month - Quantité de pluie recue depuis le début du mois.
  • This year - Quantité de pluie recue depuis le début de l'année.

6 - Recent extremes - Les données extrèmes récentes

Cet encadré présente les données minimales et maximales enregistrées dans les 2 dernières journées. Les données pour la journée en cours (Today) et précédente (Yesterday) se présentent sur 4 colonnes: Le phénomène météo, la donnée, l'unité de mesure et l'heure à laquelle a été enregistré ce "record".

  • High Wind - La vitesse de vent la plus élevée.
  • High Gust - La rafale de vent la plus élevée
  • Bearing - La direction du vent lors de la rafale.
  • Min Temp - Température la moins élevée
  • Max Temp - Température la plus élevée
  • Min Pressure - Pression minimale
  • Max Pressure - Pression maximale
  • Rain Rate - Quantité de pluie maximum recue

7 - Indoor - Données à l'intérieur

  • Temp - Température actuelle
  • Humidity - Humidité actuelle

8 - Status - État de la station

  • New record - Clignotte si un nouveau record a été enregistré.
  • Error - Indique qu'une erreur a été enregistrée sur la station
  • Catch up - Clignotte pour indiquer que Cumulus transmet présentement de l'information sur l'internet.

9 - Jauges des vents

3 cadrans représentent la vitesse, la direction et la dispersion des vents.


Cumulus Main Window

Écran Principal de Cumulus

La fenêtre principale de Cumulus affiche toutes les données météo actuelles transmises par la station météo. L'entête de cette page est modifiable dans l'option Display du menu Configuration.

L'indicateur de vitesse du vent affiche trois valeurs :

  • L'aiguille montre l'instantané actuel de la vitesse du vent, comme lue de la station météorologique. Ce que cette jauge représente exactement, dépend du type de station - en général c'est la dernière vitesse "à court terme" et correspond 'à la valeur de 'Latest" affiché sur l'écran de Cumulus.
  • La portion verte affiche la vitesse actuelle moyenne du vent. Ce qui correspond à 'Average' sur l'écran de Cumulus.
  • la section rouge indique la plus forte rafale des 10 dernières minutes. Elle correspond à 'Gust' sur l'écran de Cumulus.

Voir ci-dessous pour les informations sur les vitesses du vent.

L'indicateur de direction du vent donne l'instantané actuel de la direction de vent, telle que lue de la station météorologique représentée par une aiguille rouge (aussi indiquée par la direction au centre de la jauge). Le cadran affiche sur le pointeur bleu la direction moyenne (10 minutes) du vent indiquée par la station.

La troisième jauge donne une indication visuelle de la force relative du vent et de sa direction dans les dernières heures. Les lignes tracées prennent en compte la force du vent et la durée pendant laquelle il a soufflé dans une direction donnée.

Le témoin 'New Record' clignote chaque fois qu'un record absolu est battu. Cliquer sur le témoin permet d'ouvrir la fenêtre des Records Absolus (All Time Records).

Le témoin 'Error' clignote chaque fois qu'une erreur se produit, généralement lors d'une mise à jour du site web. Cliquer sur le témoin ouvre une fenêtre affichant les erreurs les plus récentes. D'habitude ce n'est pas inquiétant, vous pouvez vous attendre à recevoir une erreur de téléversement de temps à autre.

Le témoin lumineux 'Catch up' clignotera tandis que Cumulus débutera par des mises à jour Web pour Weather Underground etc. téléchargées de l'enregistreur de la station. Il peut s'écouler un certain délais pour ce faire. Si vous fermez Cumulus tandis que l'envoi est en cours, toutes les mises à jour exceptionnelles seront perdues.

Pour les utilisateurs de stations Davis, le statut de la pile du transmetteur est affiché dans le coin inférieur gauche de l'écran principale. Les émetteurs dont les batteries sont bonnes donnent un statut 'OK'. Malheureusement, les émetteurs qui ne sont pas présents également donnent un statut 'OK'

Dans le coin inférieur droit, une boîte de texte intitulée 'Current Conditions' est invisible jusqu'à son activation par l'option dans le menu Display Settings. Une description des conditions actuelles peut être entrée ici et la balise web <#currcond> sera remplacée par ce texte si utilisé dans une page Web traitée par Cumulus. Si un fichier appelé 'currentconditions.txt' existe dans le même dossier que l'exécutable de Cumulus, le contenu de ce fichier sera plutôt utilisé pour la balise Cumulus et lorsque la balise web est traitée, la boîte des conditions actuelles sera mise à jour avec le contenu du fichier. Le fichier sera effacé si le texte dans la boîte de conditions actuelle est modifié, s'il est en édition, ou en utilisation dans le traitement de la balise <#currcond>

La barre de statut, au bas de la fenêtre principale, affiche différents messages indiquant quand un téléversement Web surviennent et à la fin de la barre de statut est affiché le nombre d'entrées téléchargées de l'enregistreur la dernière fois que Cumulus a été lancé et la dernière fois que les données ont été lues de la station.

Une note à propos de la vitesse du vent : Aucun type de station météorologique ne fournit exactement le même type d'informations de la vitesse de vent. Habituellement, les stations météorologiques fournissent deux valeurs de vitesse de vent; une valeur à court terme (quelquefois appelé 'gust' par la station) et une valeur à long terme ou moyenne (quelque fois appelé 'average' par la station, ou simplement 'speed'). Certaines stations météorologiques fournissent seulement une valeur de vitesse de vent. Cumulus essaie de correspondre à toutes les valeurs différentes pour les trois items affichés :

  • 'Latest': c'est la dernière lecture de la vitesse 'à court terme'.
  • 'Gust': c'est la plus haute valeur dans les 10 dernières minutes 'à court terme'.
  • 'Average' : C'est la valeur à long terme ou moyenne. Quelquefois c'est pris directement de la station et d'autre fois c'est une moyenne de 10 minutes calculée par Cumulus, selon ce que vous avez demandé à Cumulus de faire, dans le menu Station Settings


Cumulus Menus

Menu Principal de Cumulus

Menu Item

Description

File
Web Update Mise à jour Web
Provoque une mise à jour immédiate du site web
Print Imprimer
Envoie une image de la fenêtre principale vers l'imprimante par défaut.
Exit Quitter
Ferme Cumulus.

Edit
All time records Records absolus
Ouvre l'écran de modification des Records permettant l'édition des records absolus..
Alarms Alarmes
Affiche l'écran des 'Alarmes' qui vous permet de metre des alarmes lorsque certaines conditions se produisent.
Copy to clipboard Envoi au presse-papier
Copie les données actuelles dans le presse papier.

View
High and Lows Maximums et minimums
All time - Affiche l'écran 'All Time Records'.

Today - Affiche les minimas et maximas du jour.

Yesterday - Affiche les minimas et maximas du jour précédent.

This month - Affiche les minimas et maximas du Mois en cours.

This year- Affiche les minimas et maximas annuels.
This month Ce mois
Affiche la fenètre du sommaire pour 'Ce mois'
This year Cette année
Affiche la fenètre du sommaire pour 'Cette année'
This period Cette période
Affiche la fenètre du sommaire pour 'Cette période'
Graphs Graphes
Affiche la fenètre des 'Graphiques'
Weather Diary Journal météo
Affiche la fenètre du 'Journal météorologique'.
Snow Index Accumulation de neige
Affiche le 'Eden Winter Snow Index'. Voir ici pour une explication.
Select-A-Graph Visonner un Graphe
Affiche l'écran 'Select-A-Graph', qui vous permet d'afficher les données sous forme de graphe.

Configuration
Station Configuration de la station
Ouvre la fenêtre Station Settings qui vous permet de paramètrer la station et d'indiquer sa localisation.
Internet Configuration Internet
Ouvre la fenêtre Internet Settings qui vous permet de paramètrer les éléments pour la publication de données sur votre page web.
Display Configurer l'affichage
Ouvre la fenêtre Display Settings qui vous permet de configurer l'apparence de Cumulus.
Debug Log Fichiers de contrôle
Selectionnez cet item pour activer le mode débogage. Des enregistrements sont effectués à des fins d'analyse. Un fichier "debug.log" est créé dans le dossier de Cumulus. Les données y sont consignées toutes les 5 minutes, ou quand vous fermez Cumulus. Notez il n'y a pas de lien avec l'historisation des données météo. SVP, ne pas activer sans que cela ne vous soit nécessaire, et ne le laissez pas actif une fois que les données souhaitées ont été obtenues.
FTP Logging Tracage FTP
Sélectionnez cette option pour effectuer un débogage FTP. Deux fichiers sont créés dans le répertoire Cumulus : "ftplog.txt" et "realtimeftplog.txt".

Help
Help topics Fichier d'aide
Affiche le fichier d'aide de Cumulus.
About À propos
Affiche les informations de Cumulus.


Cumulus "All Time Records" Records

La fenêtre "All Time Records"

(Menu: VIEW - ALL TIME RECORDS)

Cette fenêtre peut être affichée en cliquant sur le témoin d'alarme sur l'écran principal, ou en sélectionnant All time records dans le menu View. Les records actuels sont affichés; si un record a été brisé depuis la dernière fois que cette fenêtre a été consultée, la lumière à côté de cette entrée clignotera. Cliquer sur sur la lumière l'arrêtera, et fermer la fenêtre éteindra toutes les lumières.


Cumulus 'This Month' Window

La fenêtre 'This Month' (Ce mois)

(Menu: VIEW - THIS MONTH)

Cette fenêtre peut être affichée en sélectionnant 'This Month' dans le menu 'View'. Différentes statistiques du mois en cours sont affichées.

Les autres mois peuvent être affichés en utilisant les boîtes de dialogue 'Month' (mois) et 'Year' (année), puis en cliquant sur le bouton 'Update display'.

Les données affichées peuvent être copiées dans le presse-papiers (pour les poster dans un article Usenet, par exemple) en cliquant sur 'Copy to clipboard'.

Notez que les données du mois affiché en cours n'incluent pas les données du jour.


Cumulus - La fenêtre 'Graphs'

La fenêtre 'Graphs'

(Menu: VIEW - GRAPHS)

Cette fenêtre est affichée en sélectionnant 'Graphs' dans le menu 'View'.

Les données des grands graphe sont actualisées toutes les minutes (excepté les Températures Min/Max, et les précipitations quotidiennes qui sont des données quotidiennes), alors que les données dans les petits graphes sont actualisées toutes les 10 minutes.

Un clique droit sur le grand graphe ouvre un menu contextuel qui permet de changer les couleurs des courbes.

Un clique droit sur un graphe de température ou d'humidité extérieure permet aussi de sélectionner quel item sera présenté sur ces graphes.

Vous pouvex changer le libellé des graphes en utilisant le fichier 'strings.ini'; référez vous à la page de Wiki suivante: - http://wiki.sandaysoft.com/a/Strings.ini

Le fait de cliquer sur un des petits graphiques fait apparaître sa version plus grande dans la fenêtre du grand graphe. Vous pouvez agrandir une région du grand graphique en traînant la souris; pour réduire, traîner du bas à droite jusqu'au haut gauche.

Notez que si vous téléversez les images de graphique sur votre site Internet, ils apparaîtront exactement comme ils le sont dans Cumulus - c'est-à-dire que si vous avez agramdi les graphes, c'est ainsi qu'ils apparaîtront dans votre site.


Cumulus Logs Window

Fenêtre « Journal météo »

(Menu: VIEW - WEATHER DIARY)

Cette fenêtre peut être affichée en sélectionnant 'Weather Diary' dans le menu 'View'.

L'option de journal météotologique permet de saisir de courtes notes (jusqu'à 1024 caractères) pour chaque jour, et d'enregistrer éventuellement des chutes ou la présence de neige, ainsi que l'épaisseur de la couche de neige.

Pour enregistrer une note :

Sélectionnez la date dans le calendrier en cliquant dessus, puis entrez les détails voulus. Cliquez sur 'update' pour enregistrer la saisie.

Cliquez sur le bouton 'Close' pour fermer la fenêtre, et sauvegarder la note dans le fichier d'historique.

Pour modifier une note :

Sélectionnez la date dans le calendrier en cliquant dessus, puis modifiez les détails voulus. Cliquez sur 'update' pour enregistrer la saisie.

Cliquez sur 'Close' pour fermer la fenêtre, et sauvegarder la note dans le fichier d'historique.


The Select-A-Graph Display

L'écran 'Select-A-Graph'

(Menu: VIEW - SELECT-A-GRAPH)

Cet écran peut être affiché en sélectionnant 'Select-A-Graph' dans le menu 'View'. Cet écran vous permet d'afficher des données historiques sous forme de graphiques. Choisissez les éléments à afficher en cochant les cases correspondantes, sélectionnez les dates et heure de début et de fin, et cliquez sur le bouton ‘Update’ pour afficher le graph choisi. Notez que certaines combinaisons de paramètres peuvent ne pas produire des résultats esthétiques, comme ils doivent tous utiliser la même échelle pour l'axe des Y.

Vous pouvez changer la couleur des lignes du graphe en utilisant le bouton ‘Colour’, vous pouvez aussi choisir un affichage en 2D ou en 3 dimensions, en sélectionnant la case 'Display 3D'.

Le graph peut être imprimé ou enregistré en mode PNG en sélectionnant simplement 'Print' dans le menu 'File'.

Vous pouvez assigner chaque item à l'axe gauche ou droite, ce qui aide en comparant deux items qui ont de grandes différences dans leurs échelles, par exemple rayonnement solaire et index UV.

Vous pouvez cliquer le bouton 'Clear' quand vous avez fini avec Select-A-Graph pour effacer les graphs et libérer la mémoire utilisée (qui peut être considérable pour une grande échelle).


Les éditeurs de records maximums et minimums

Les éditeurs de records (maximum et minimum)

L'édition se fait en sélectionnant dans le menu EDIT: All time records, Monthly records, This month's records, ou This year's records.

Les records en cours sont affichés; les valeurs, les dates et les heures peuvent être changés par l'édition la boîte appropriée. Cliquer sur 'Fetch log data' déclenchera un balayage de tous vos fichiers d'historique mensuel pour y relever les valeurs maximales et minimales; celles-ci seront alors affichées dans la grille, dans la colonne 'Log value' (valeur enregistrée), et la colonne adjacente 'Timestamp' (horodatage); redimensionnez la fenêtre si elles ne sont pas visibles. De même, en cliquant sur 'Fetch dayfile data' vous déclencherez le balayage du fichier dayfile.txt à la recherche des maximums et minimums, qui seront affichés dans la colonne 'Dayfile value' (valeur selon Dayfile) et la colonne adjacente 'Timestamp' (horodatage); redimensionnez la fenêtre si elles ne sont pas visibles. Vous pouvez copier l'une ou l'autre des valeurs trouvées (avec leur date et heure) pour remplacer la valeur de 'current' (actuelle) dans la grille, en cliquant sur au bouton 'copy' approprié. Cliquer sur le bouton 'reset' fera apparaître le record existant de nouveau. Dans l'éditeur de record mensuel (Monthly record), cliquer sur les boutons 'reset' ou 'copy' dans l'en-tête applique l'action courante sur toutes les rangées.

Notez qu'en cherchant les minimums et maximums à partir des fichiers d'historique, c'est vraiment beaucoup une question de "déchets en entrée, déchets en sortie". Si vous avez des erreurs quelconques dans vos fichiers d'historique (provoqués par de mauvaises données, des bogues de Cumulus présentement ou à un moment donné dans le passé, etc.) celles-ci apparaîtront dans la grille, et vous pourrez constater que vous souhaitez les éditer à partir des fichiers d'historique avant d'essayer de nouveau. Pour certains items, Cumulus peut ne pas pouvoir retrouver de valeur; ce sera habituellement parce qu'il n'est pas possible de déterminer cet item particulier à partir des fichiers d'historique (par exemple. Les totaux mensuels de pluie ne peuvent pas être déterminés à partir des fichiers d'historique mensuels, mais seulement è partir de dayfile.txt).

Important: Même si vos données sont parfaites à 100%, ne comptez pas voir toutes les valeurs recherchées convenir exactement. C'est dû au fait que les fichiers d'historique sont des "instantanés" des données, ayant pu ne pas avoir attrapé réellement un maximum ou un minimum particulier. La possibilité est simplement là de sorte que vous puissiez rechercher une bonne valeur pour remplacer un record existant qui a pu avoir été corrompu d'une façon quelconque. En outre, parce que la liste de données de base (les maximums et minimums) enregistrés par Cumulus ont changés au fil des ans, un record particulier ne peut pas actuellement retourner complètement au début de vos données, ainsi vous pouvez employer le balayage des fichiers d'historique pour trouver une meilleure valeur. Pour la température apparente et l'indice de chaleur, lesquels Cumulus a seulement commencé l'enregistrement relativement récemment, il calculera rétrospectivement ces valeurs à partir des valeurs de température, d'humidité, et de vitesse du vent, pour ces entrées plus anciennes qui ne contiennent pas les items elles-mêmes.

Quand vous êtes satisfaits de ces modifications, cliquez sur le bouton OK pour les enregistrer. Sinon, cliquez le bouton 'Cancel' pour ne pas sauvegarder ces changements.


éditeurs de records pour le fichier 'Dayfile.txt'

L'éditeurs de records pour le fichier 'Dayfile.txt'

L'édition se fait en sélectionnant dans le menu EDIT: Dayfile.txt.

Notes : la touche d'effacement supprimera la rangée actuelle ; il n'y a aucune manière de supprimer une cellule. La touche d'insertion insère une rangée avant la rangée actuelle (cliquez sur une cellule pour en faire la rangée courante). L'éditeur n'a aucune intelligence au sujet des types de données dans chaque cellule, tout est traité comme du texte. Assurez-vous d'employez les formats adéquats.

Lorsque vous avez terminé l'édition, cliquez sur le bouton OK pour enregistrer les valeurs de la grille dans le fichier dayfile.txt. Sinon, cliquez sur le bouton 'Cancel' pour rejeter tous les changements.

L'option 'Create Missing' tente de recréer les entrées absentes en se basant sur les données qu'il peut trouver dans les fichiers d'historique mensuels. Elle n'est pas parfaite, et naturellement elle se fonde sur les données dans les fichiers d'historique mensuels comme étant CORRECTS. Il crée un fichier dans le dossier de cumulus appelé dayfileeditlog.txt qui contient les entrées qu'elle a créées - elle crée ce fichier même si vous cliquez sur 'Cancel', ainsi vous pouvez voir ce qu'il aurait ajouté si vous aviez cliqué sur OK. Elle ne fait aucune tentative pour recréer des valeurs pour "les précipitations horaires maximales" mais fait du mieux qu'elle peut avec toutes les autres.


Setting Alarms

L'écran 'Alarmes'

(Menu: EDIT - ALARM)

Cet écran peut être affiché en sélectionnant Alarms dans le menu Edit. Vous pouvez définir une alarme pour des conditions variées, par exemple si la température tombe en desous d'une certaine valeur. Entrez la valeur souhaitée dans la case appropriée, et cochez la case 'Alarm if...' pour activer l'alarme. Vous pouvez également définir un signal sonore quand l'alarme se déclenche en cochant la case 'Play sound'. Un signal sonore par défaut est activé, mais vous pouvez en choisir un autre pour chaque alarme en cliquant sur le bouton 'Choose sound' (fichier .wav uniquement)

Quand une alarme se déclenche, le titre de l'élément déclenchant l'alarme devient rouge. Si vous cliquez sur l'étiquette, elle redevient noire, et l'alarme est réinitialisée. Notez qu'elle peut se re-déclencher immédiatement. Si vous ne cliquez pas sur l'étiquette, et que la condition de déclenchement n'est plus remplie (par exemple, la température remonte au dessus du seuil de déclenchement) l'étiquette devient bleue pour indiquer que l'alarme fut déclenchée. Cliquez dessus à nouveau pour que'elle passe au noir et soit réinitialisée.


Fichier d'aide pour Cumulus v1.9.4

Logo de Cumulus Weather Software

Création d'un Site Web

Dans cette section, nous vous montrerons en bref comment utiliser Cumulus v.1.9.4, pour créer votre propre Site Internet Météo. Que ce soit avec le modèle standard inclu avec Cumulus pour une installation simple, en quelques minutes ou pour un site élaboré à l'aide des 'Balises Cumulus' vous trouverez toute l'information utile dans les sections ci-dessous.

L'information est répartie dans 2 sections, à savoir:

  • Préparer votre Site Web - Les fichiers essentiels à toute installation.
  • Balises Web - Le secret de la puissance de Cumulus.

Version 0.5 - Novembre 2013


Configurer son site web avec Cumulus

Préparer votre site web

Cumulus peut créer des pages web toutes prêtes, et les envoyer automatiquement sur votre site Internet. Pour ce faire, vous devez effectuer une petite préparation à ne faire qu'une fois. En plus de fournir les paramètres du site web dans le paramétrage Internet de Cumulus (Internet Settings), vous devez effectuer ces quelques petits travaux de préparation de votre site web :

D'abord, choisissez le nom du répertoire où vous stockerez les pages météo dans votre espace web.- C'est ce nom qui doit être entré dans les paramètres Internet (Internet Settings). Connectez vous sur votre espace web (normalement, c'est un serveur ftp), et créez ce répertoire. Vous pouvez mettre votre site météo Cumulus à la 'racine' de votre espace Web si vous le souhaitez, vous n'auriez normalement pas besoin alors de créer un répertoire pour lui.

Vous devez maintenant envoyer quelques fichiers. Ils sont disponibles sur votre ordinateur dans le répertoire webfiles ou vous avez installé Cumulus. Copiez le contenu du répertoire webfiles (non pas le dossier lui-même) sur votre site Web. Les fichiers et dossiers suivants doivent être téléversés dans le répertoire désigné dans les paramètres Internet (Internet Settings)

  • weatherstyle.css
  • wz_jsgraphics.js
  • répertoire dbimages et tout son contenu
  • répertoire images et tout son contenu
  • CumulusRealtime.swf

CumulusRealtime.swf est une application Adobe Flash qui affiche la vitesse et la direction du vent en temps réel, quand il est utilisée avec les paramètres 'real time'; activé dans la Configuration Internet (Internet Settings). Un exemple d'utilisation est donné dans la page web modèle (gaugesT.htm). Si vous ne voulez pas utiliser l'affichage en temps réel, vous n'avez pas besoin du fichier flash, et vous pouvez éditer le fichier gaugesT.htm pour enlever la section qui intègre l'affichage. Les instructions nécessaires sont dans le fichier gaugesT.htm.

Dans le dossier images sur votre site Web, vous aurez maintenant un fichier picture.jpg, c'est le fond d'image pour les pages Web. Vous pouvez créer votre propre version de ce fichier; l'image fournie est une photo d'un fulmar. Ou vous pouvez omettre le fichier totalement si le vous souhaitez.

Exemple: Vous souhatez que vos pages météo apparaissent à cette adresse: http://VotreDomaine.com/meteo

À la racine de votre site web, créez le dossier et la structure de fichier suivante:

  • meteo (dossier)
    • weatherstyle.css
    • wz_jsgraphics.js
    • CumulusRealtime.swf
    • images (dossier)
      • picture.jpg
    • dbimages (dossier)
      • barometer2.gif
      • boxover.js
      • cloudbase.gif
      • dashboard.js
      • Falling.gif
      • humidl.gif
      • humids.gif
      • rainl10.gif
      • rainl100.gif
      • rainl200.gif
      • rainl400.gif
      • rains10.gif
      • rains100.gif
      • rains200.gif
      • rains400.gif
      • Rising.gif
      • Steady.gif
      • thermol.gif
      • thermos.gif
      • windrose10.gif
      • windrose120.gif
      • windrose20.gif
      • windrose40.gif
      • windrose80.gif


Cumulus v1.9.4 - les Webtags expliqués

Les Balises Web (Webtag) de Cumulus, v1.9.4

Si vous ne souhaitez pas utiliser les pages Web standard fournies avec Cumulus, vous pouvez concevoir vos propre pages et demander à Cumulus d'y insèrer automatiquement les données avant de les téléverser sur votre site Internet. Vous le faites en utilisant des Balises transparentes pour vos pages HTML, sous la forme

<#balise>

Tout de suite avant le téléversement du fichier, Cumulus remplacera la balise par la valeur actuelle que la balise représente. Quand vous mettez des balises dans votre page HTML, assurez-vous que le programme que vous utilisez pour développer vos pages Web ne change pas les crochets < et >. Plusieurs programmes semblent le faire!

Voici une liste des balises que vous pouvez utiliser. Notez qu'elles sont sensibles à la casse.

Balise Web | Fonction
<#time> | La date et l'heure. Si vous souhaitez simplement le temps, utilisez une combinaison des Webtag journée, mois, année (ci-dessous). Exemple: 14:13 on 09 mai 2010
<#yesterday> | Date d'hier
<#timeUTC> | L'heure et la date actuelle, en UTC. Format par défaut : 17:30 on 14 May 2004
<#timehhmmss> | L'heure actuelle. Exemple: 14:13:37
<#day> | Aujourd'hui est un nombre à 2 chiffres. Exemple: 09
<#dayname> | Le jour courant en un mot. Exemple: samedi
<#shortdayname> | Le jour courant en abbrégé. Exemple: sam.
<#month> | Le mois en cours est un nombre à 2 chiffres. Exemple: 10
<#monthname> | Le mois en cours en un mot. Exemple: octobre
<#shortmonthname> | Le mois en cours en abrégé. Exemple: oct.
<#year> | L'année en cours, un nombre à 4 chiffres. Exemple: 2010
<#shortyear> | L'année en cours, un nombre à 2 chiffres. Exemple: 10
<#hour> | L'heure présente, un nombre à 2 chiffres. Exemple: 14
<#minute> | La minute présente, un nombre à 2 chiffres. Exemple: 13
<#date> | La date courante Exemple: 2010-10-09
<#metdate> | La date'météorologique' actuelle. Tenez compte que votre jour météorologique débute à minuit ou 0900/1000.
<#metdateyesterday> | La date 'météorologique' d'hier. Tenez compte que votre jour météorologique débute à minuit ou 0900/1000.
<#DaysSince30Dec1899> | Je nombre de jours (entier et fraction) depuis le 30 Déc 1899
<#forecast> | Prévision actuelle Comme configurée dans Cumulus (c.-à-d. prévision de cumulus ou de la station météorologique) Exemple: Précipitations occasionnelles, se dégradant
<#forecastenc> | Identique à <#forecast> mais avec tous les caractères réservés du HTML, et ceux au-dessus du code de caractère 159, codé comme entités de HTML
<#cumulusforecast> | La prévision courante, tel que déterminé par Cumulus, qui exploite l'algorithme de 'Zambretti'.
<#cumulusforecastenc> | Identique à <#cumulusforecast> mais avec tous les caractères réservés du HTML, et ceux au-dessus du code de caractère 159, codé comme entités de HTML
<#wsforecast> | La prévision actuelle, tel que déterminé par la station météo (si disponible).
<#wsforecastenc> | Identique à <#wsforecast> mais avec tous les caractères réservés du HTML, et ceux au-dessus du code de caractère 159, codé comme entités de HTML
<#temp> | La température extérieure.
<#IsFreezing> | Retourne 1 si la températuer actuelle est sur le point de congélation ou en dessous, sinon retourne 0
<#avgtemp> | La température extérieure moyenne pour aujourd'hui pour l'instant. Calculé par échantillons pris aux intervalles de 1 minutes. Exemple: 21,7
<#avgtempY> | La température extérieure moyenne d'hier. Calculé par échantillons pris aux intervalles de 1 minutes. Exemple: 21,7
<#apptemp> | La température 'apparente' (formule de BOM australie) Exemple: 29,1
<#temprange> | L'écrat de température (max - min) jusqu'à présent aujourd'hui.
<#temprangeY> | L'écrat de température (max - min) d'hier
<#intemp> | La température intérieure Exemple: 21,1
<#hum> | Humidité extérieure actuelle. Exemple: 42
<#inhum> | L'humidité intérieure actuelle. Exemple: 53
<#press> | Pression au niveau de la mer. Exemple: 1006,5
<#altimeterpressure> | Pression d'altimètre. La pression corrigée au niveau de la mer en utilisant l'altitude seulement. La même que la pression au niveau de la mer pour les stations non-Davis. Exemple: 1006,5
<#presstrend> | Tendance de la pression en mots (éditable dans le fichier string.ini). Exemple: Chute lente
<#presstrendenglish> | Description en un mot pour la tendance de la pression - Rising/Falling/Steady. Utiles pour les jauges en Javascript, les valeurs peuvent être éditées. Exemple: Falling
<#presstrendval> | Tendance de la pression en figure Exemple: -0,4
<#dew> | Le point de rosée à l'extérieur Exemple: 0,4
<#wetbulb> | La température estimée du 'thermomètre mouillé' actuellement
<#rrate> | Le taux de précipitation actuel Exemple: 0,0
<#wchill> | Le Facteur Éolien actuel Exemple: 13,4
<#wgust> | La lecture de vent la plus élevée au cours des 10 dernières minutes. Correspond à 'gust' sur l'écran principal de Cumulus. Exemple: 27,0
<#wspeed> | La vitesse actuelle moyenne du vent. Correspond à 'average' sur l'écran principal de Cumulus. Exemple: 7,8
<#wlatest> | La dernière lecture de la vitesse du vent de la console. Correspond à 'latest' sur l'écran principal de Cumulus. Exemple: 17,3
<#bearing> | La direction actuelle du Vent, telle que lue de la console. Exemple: 270
<#BearingRangeFrom> | La 'plus basse' direction dans les dernières 10 minutes (ou tel que configuré en utilisant AvgBearingMinutes dans le fichier cumulus.ini)
<#BearingRangeTo> | The 'highest' bearing in the last 10 minutes (or as configured using AvgBearingMinutes in cumulus.ini)
<#BearingRangeFrom10> | La 'plus basse' direction dans les dernières 10 minutes (ou tel que configuré en utilisant AvgBearingMinutes dans le fichier cumulus.ini), arrondi au 10 degrés inférieur le plus près
<#BearingRangeTo10> | La 'plus haute' direction dans les dernières 10 minutes (ou tel que configuré en utilisant AvgBearingMinutes dans le fichier cumulus.ini), arrondi au 10 degrés supérieur le plus près
<#currentwdir> | Direction actuelle du vent, comme un point sur une boussole. Exemple: W
<#avgbearing> | Direction moyenne du vent pendant les derniers 10 minutes (ou tel que configuré avec AvgBearingMinutes dans le fichier cumulus.ini). Exemple: 267
<#wdir> | Direction moyenne du vent (sur 10 mins.) comme un point de boussole. Exemple: ESE
<#wdirdata> | Liste des dernières lectures de la direction du vent, séparées par des virgules (jusqu'à 3600 entrées). Il s'agit d'un tampon circulaire; pour trouver la valeur la plus récente utilisez nextwindindex. Exemple: 225,225,180,180...
<#wspddata> | Liste des dernières lectures de la vitesse du vent, séparées par des virgules (jusqu'à 3600 entrées). Il s'agit d'un tampon circulaire; pour trouver la valeur la plus récente utilisez nextwindindex. Exemple: 225,225,180,180...
<#WindSampleCount> | Le nombre actuel d'entrées dans wdirdata et wspddata.
<#nextwindindex> | L'index des entrées de wdirdata et wspddata que Cumulus utilisera à l'étape suivante - La dernière entrée utilisée est un de moins que cela, mais ne pas oublier de prévoir pour l'enrobage. Exemple: 1639
<#WindRoseData> | La liste, séparée par des virgules, des valeurs actuellement employées pour produire la Rose des Vents. Les valeurs sont les totaux des vitesses du vent dans chaque direction. Le premier chiffre correspond au Nord, et les chiffres continuent dans le sens horaire. Le nombre d'échantillons employés pour produire la Rose des Vents peut être trouvé par la Balise Cumulus WindSampleCount.
<#WindRosePoints> | Le nombre de points de compas sur la Rose des Vents (8 ou 16)
<#windrun> | Le parcours total du vent jusqu'à aujourd'hui Exemple: 80,5
<#windrunY> | Le parcours total du vent d'hier Exemple: 142,6
<#domwindbearing> | The 'dominant' (average) wind bearing so far today, in degrees
<#domwinddir> | La direction 'dominante' (moyenne) du vent pour l'instant aujourd'hui, en point de compas - ex ESE
<#domwindbearingY> | La direction 'dominante' (moyenne) du vent d'hier, en degrés
<#domwinddirY> | La direction 'dominante' (moyenne) du vent d'hier, en point de compas - ex ESE
<#heatdegdays> | Le degré-jours chauffage pour l'instant aujourd'hui
<#cooldegdays> | Le degré-jours climatisation pour l'instant aujourd'hui
<#heatdegdaysY> | Le degré-jours chauffage d'hier
<#cooldegdaysY> | Le degré-jours climatisation d'hier
<#rfall> | Le total des précipitations jusqu'à aujourd'hui Exemple: 0,0
<#rfallY> | Le total des précipitations pour hier Exemple: 0,0
<#rmidnight> | Le total des précipitations depuis minuit. Utile si vous n'utilisez pas minuit comme début de journée Exemple: 0,0
<#rhour> | Le taux de précipitation dans la dernière heure Exemple: 0,0
<#r24hour> | Le taux de précipitation dans les dernières 24 heures Exemple: 0,0
<#rmonth> | Total des précipitations jusqu'à présent pour le mois en cours. Exemple: 25,5
<#ryear> | Total des précipitations jusqu'à présent cette année Exemple: 303,6
<#battery> | État de la pile de la console. Stations météo Davis seulement. Exemple: 0v
<#txbattery> | État de la pile de l'émetteur de la station météo. Stations Davis seulement. Ceci donne une chaîne créée par le logiciel de Davis qui donne l'état des batteries de tous les émetteurs possibles. Les émetteurs qui ne sont pas présents donnent 'OK'. La Balise Web a un paramètre 'channel', ainsi vous pouvez demander le statut individuellement pour un canal (1 à 8), par exemple. <#txbattery channel=1> vous donnera 'ok' si la pile du transmetteur est correcte, autrement affiche 'Low' Exemple: No status
<#beaufort> | La vitesse actuelle du vent sur l'échelle de Beaufort Exemple: F2
<#beaufortnumber> | La vitesse actuelle du vent sur l'échelle de Beaufort - Le nombre seulement (ex. 8)
<#beaudesc> | Vitesse du vent selon la description de Beaufort Exemple: Brise légère
<#temptrend> | Le changement de température au cours de la dernière heure Exemple: +1,0
<#TempChangeLastHour> | Le changement de température dans la dernière heure.
<#temptrendtext> | Changement de température au cours de la dernière heure - Hausse/Baisse/Stable. (éditable dans le fichier string.ini) Exemple: Hausse
<#temptrendenglish> | Description simple du changement de température au cours de la dernière heure - Hausse/Baisse/Stable. Utiles pour les jauges en Javascript, les valeurs peuvent être éditées.. Exemple: Rising.
<#heatindex> | Indice de chaleur actuel Exemple: 13,7
<#humidex> | Humidex actuel. Voir cet article de Wikipédia. Exemple: 13,7
<#cloudbase> | Hauteur théorique à laquelle les nuages de types Cumulus commencent à se former. Exemple: 5458 ft
<#cloudbasevalue> | Hauteur théorique à laquelle les nuages de types Cumulus commencent à se former (nombre seulement. ex. 1200)
<#ET> | L'evapotranspiration aujourd'hui. Exige une station avec capteur solaire. Seulement sur les stations Davis.
<#UV> | Index UV actuel. Requière une station avec capteur UV.
<#SolarRad> | Rayonnement solaire actuel en W/m2. Requière une station avec capteur solaire.
<#Light> | Niveau de lumière en Lux. Requière une station avec un capteur solaire. S'applique seulement aux stations Fine Offset.
<#THWindex> | Indice Température/Humidité/Vent actuel. Seulement sur les stations Savis.
<#THSWindex> | Indice Température/Humidité/Soleil/Vent actuel. Requière une station ayant un capteur solaire. S'applique seulement aux stations Davis. Notez qu'il semble y avoir un bogue dans le code de Davis ce qui signifie qu'il retourne toujours zéro.
<#snowdepth> | Couverture de neige aujourd'hui comme saisis manuellement dans le journal météo. Normalement en Centimetètres. La sortie est une donnée numérique soit 10.
<#currcond> | Le contenu de la boîte 'Current Conditions' sur l'écran principal (tel qu'entré manuellement). Si un fichier appelé 'currentconditions.txt' existe dans le même dossier que l'exécutable de Cumulus, le contenu de ce fichier sera utilisé plutôt, et lorsque la Balise Web sera traitée, la boîte actuelle de conditions sur l'écran principal sera mise à jour avec ce contenu. Le fichier sera effacé si le texte dans la boîte de conditions actuelle est modifié, en étant éditée, ou si le fichier est employé dans le traitement de la balise <#currcond>. Les caractères réservés de HTML sont codés comme entités HTML. Exemple:
<#currcondenc> | Identique à <#currcond> mais en plus, tous les caractères audessus du code 159 sont encodés comme des entités HTML.
<#LastRainTipISO> | Date et heure de la dernière lecture du pluviomètre. en format ISO 8601 : aaaa-mm-jj hh:mm Exemple: 2010-10-07 15:51
<#MinutesSinceLastRainTip> | Le nombre de minutes depuis la dernière lecture de pluie, tronqué à l'entier le plus près.
<#SunshineHours> | Les heures d'ensoleillement pour l'instant aujourd'hui. Votre station doit avoir un détecteur solaire. Exemple: 11,3
<#YSunshineHours> | Les heures de soleil pour hier. Votre station doit avoir un détecteur solaire. Exemple: 10,4
<#CurrentSolarMax> | Radiation solaire théorique maximale pour votre localisation. Exemple: 12
<#IsSunny> | Retourne 1 si le soleil brille, autrement 0. Votre station doit avoir un détecteur solaire.
<#chillhours> | Le nombre d'heures de refroidessement éolien jusqu'ici cette année. La température de seuil est configurable, de même que le début de l'année, par l'intermédiaire des paramètres de cumulus.ini.
<#ConsecutiveRainDays> | Le nombre de jours jusqu'à (mais comprenant ne pas) aujourd'hui où il a plu chaque jour. La quantité du seuil de pluie exigée pour déterminer un jour de pluie est configurable par l'intermédiaire du paramètre RainDayThreshold dans cumulus.ini
<#ConsecutiveDryDays> | Le nombre de jours jusqu'à (mais ne comprenant pas) aujourd'hui où il n'y a pas eu de la pluie. La quantité du seuil de pluie exigée pour déterminer un jour de pluie est configurable par l'intermédiaire du paramètre RainDayThreshold dans cumulus.ini.
<#LatestNOAAMonthlyReport> | Si vous avez configuré Cumulus pour créer automatiquement les rapports de style NOAA, cette balise donne le nom de fichier du dernier rapport mensuel créé.
<#LatestNOAAYearlyReport> | Si vous avez configuré Cumulus pour créer automatiquement les rapports de style NOAA, cette balise donne le nom de fichier du dernier rapport annuel créé.
<#IsRaining> | Si vous avez un capteur de pluie de type RG-11 configuré en mode 'il pleut', retourne 1 quand le capteur dit qu'il pleut et 0 quand il dit qu'il ne pleut pas
<#RG11RainToday> | Si vous avez un capteur de pluie de type RG-11 configuré en mode 'augets basculeurs', ce qui donne le total de pluie pour l'instant aujourd'hui selon la sonde
<#RG11RainYest> | Si vous avez un capteur de pluie de type RG-11 configuré en mode 'augets basculeurs', cette Balise donne le total de pluie d'hier selon la sonde

Il y a un ensemble de balises pour les maximums et minimums du jour, par ex. <#tempTH> est la température maximale du jour et <#tempTL> est la température minimale du jour; <#TtempTH> est l'heure à laquelle la température maximale s'est produite, et ainsi de suite. La liste complète de cet ensemble de balises suit; vous devriez être en mesure de comprendre ce qu'elles représentent par leurs noms. Notez que <#bearingTM> est la direction de vent au moment du plus fort coup de vent (<#wgustTM>).

<#tempTH> | <#pressTH> | <#windTM> | <#wgustTM> | <#rrateTM>
<#TtempTH> | <#TpressTH> | <#TwindTM> | <#TwgustTM> | <#TrrateTM>
<#tempTL> | <#pressTL> | <#bearingTM> | <#humTH> | <#humTL>
<#TtempTL> | <#TpressTL> | <#Tbeaufort> | <#Tbeaufortnumber> | <#Tbeaudesc>
<#ThumTH> | <#ThumTL> | <#heatindexTH> | <#apptempTH> | <#apptempTL>
<#wchillTL> | <#hourlyrainTH> | <#dewpointTH> | <#dewpointTL> | <#solarTH>
<#UVTH> |

Notez que la Balise <#Tbeaufort> inclue la lettre "F" (pour la "Force"), ex. "F6". La Balise <#Tbeaufortnumber> fourni seulement le chiffre, ex. "6".

Il y a un ensemble de balises correspondantes pour les maximums et minimums d'hier, en replaçant le T par un Y par ex: <#tempYH>.

Il y a aussi un ensemble de balises pour les records absolus de maximums et minimums, comme suit:

<#tempH> | Plus haute température jamais enregistrée Exemple: 35,1
<#tempL> | Plus basse température jamais enregistrée Exemple: 0,1
<#apptempH> | Plus haute température apparente jamais enregistrée Exemple: 35,1
<#apptempL> | Plus basse température apparente jamais enregistrée Exemple: 0,1
<#dewpointH> | Plus haut point de rosée jamais enregistrée Exemple: 2,3
<#dewpointL> | Plus bas point de rosée jamais enregistrée Exemple: 22,9
<#humH> | Plus haute humidité jamais enregistrée Exemple: 100
<#humL> | Plus basse humidité jamais enregistrée Exemple: 21
<#gustM> | Rafale de vent maximale jamais enregistré Exemple: 50,0
<#wspeedH> | Vitesse du vent maximale jamais enregistré Exemple: 24,8
<#windrunH> | Parcours du vent macimal jamais enregistré
<#wchillH> | Plus fort refroidissement éolien jamais enregistré (c-à-d. la plus basse température). Exemple: -44,8
<#heatindexH> | Plus haut indice de chaleur. Exemple: 41,4
<#rrateM> | Plus haut taux de pluie jamais enregistré Exemple: 79,2
<#rfallH> | Plus haut taux de pluie quotidien jamais enregistré Exemple: 63,3
<#rfallhH> | Plus haut taux horaire de pluie jamais enregistré Exemple: 17,1
<#rfallmH> | Plus haut taux mensuel de pluie jamais enregistré Exemple: 165,3
<#pressH> | Plus haute pression jamais enregistrée Exemple: 1027,8
<#pressL> | Plus basse pression jamais enregistrée Exemple: 988,9
<#mintempH> | Plus haut minimum jamais enregistrée Exemple: 20,7
<#maxtempL> | Plus bas maximum jamais enregistrée Exemple: 13,5
<#LongestDryPeriod> | Plus longue période sans pluie jamais enregistrée (en jours)
<#LongestWetPeriod> | Plus longue période de pluie jamais enregistrée (en jours)
<#LowDailyTempRange> | Plus petit écrat de température jamais enregistré
<#HighDailyTempRange> | Plus grand écrat de température jamais enregistré

Chacune des balises ci-haut possède une balise date/heure correspondante, créé en préfixant un T majuscule, par ex. <#TtempH>, qui donnent la date et l'heure sous la forme "at 17:39 on 21 septembre 2007". Le temps sera formaté selon votre configuration de Windows. Vous pouvez personnaliser le format de date en utilisant le paramètre 'format' pour chaque balise, voir ci-dessous.

Il y a aussi un ensemble de balises pour les minimums et maximums pour chacun des mois, en d'autres termes, les maximums et minimums pour un mois donné. Par exemple, la température la plus élevée pour un mois de juillet. Chaque Balise a un paramètre facultatif "mon=N" où N est l'index du mois de l'année dont vous voulez la valeur (janvier=1 et ainsi de suite). Par exemple, <#ByMonthTempH mon=7> vous donnerait la température maximale pour un mois de juillet.

Si vous ne fournissez pas de paramètre (ou fournissez un paramètre invalide) le mois actuel sera employé. Vous pouvez adapter les formats de temps en utilisant le paramètre 'format' sur la balise Web, voir ci-dessous.
Pour spécifier plus d'un paramètre, séparez les par un espace, ex. <#ByMonthTempHT mon=7 format=hh:nn>

Description | Valeur | Temps
Température maximale | <#ByMonthTempH> | <#ByMonthTempHT>
Température minimale | <#ByMonthTempL> | <#ByMonthTempLT>
Indice de chaleur maximal | <#ByMonthHeatIndexH> | <#ByMonthHeatIndexHT>
Refroidissement éolien min. | <#ByMonthWChillL> | <#ByMonthWChillLT>
Température ressentie max. | <#ByMonthAppTempH> | <#ByMonthAppTempHT>
Température ressentie min. | <#ByMonthAppTempL> | <#ByMonthAppTempLT>
Point de rosée maximal | <#ByMonthDewPointH> | <#ByMonthDewPointHT>
Point de rosée minimal | <#ByMonthDewPointL> | <#ByMonthDewPointLT>
Plus haut Minimum Quotidien | <#ByMonthMinTempH> | <#ByMonthMinTempHT>
Plus bas Maximum Quotidien | <#ByMonthMaxTempL> | <#ByMonthMaxTempLT>
Pression maximale | <#ByMonthPressH> | <#ByMonthPressHT>
Pression minimale | <#ByMonthPressL> | <#ByMonthPressLT>
Humidité maximale | <#ByMonthHumH> | <#ByMonthHumHT>
Humidity minimale | <#ByMonthHumL> | <#ByMonthHumLT>
Rafale maximum | <#ByMonthGustH> | <#ByMonthGustHT>
Vitesse du vent max. | <#ByMonthWindH> | <#ByMonthWindHT>
Parcours du vent quotidien max. | <#ByMonthWindRunH> | <#ByMonthWindRunHT>
Taux de pluie maximum | <#ByMonthRainRateH> | <#ByMonthRainRateHT>
Averse maximale en 1h | <#ByMonthHourlyRainH> | <#ByMonthHourlyRainHT>
Pluie recue, max en 1 jour. | <#ByMonthDailyRainH> | <#ByMonthDailyRainHT>
Période max. sans pluie | <#ByMonthLongestDryPeriod> | <#ByMonthLongestDryPeriodT>
Période max. de pluie | <#ByMonthLongestWetPeriod> | <#ByMonthLongestWetPeriodT>
Écart de température max. quotidien | <#ByMonthHighDailyTempRange> | <#ByMonthHighDailyTempRangeT>
Écart de température min. quotidien | <#ByMonthLowDailyTempRange> | <#ByMonthLowDailyTempRangeT>

Il y a un ensemble de Balises pour les maximums et minimums pour le mois en cours. Vous pouvez adapter les formats de temps en utilisant le paramètre 'format' sur la Balise Web, voir ci-dessous.

Description | Valeur | Heure (format court) | Date (jour et mois long)
Température maximale | <#MonthTempH> | <#MonthTempHT> | <#MonthTempHD>
Température minimale | <#MonthTempL> | <#MonthTempLT> | <#MonthTempLD>
Indice chaleur max. | <#MonthHeatIndexH> | <#MonthHeatIndexHT> | <#MonthHeatIndexHD>
Ref. Éolien min. | <#MonthWChillL> | <#MonthWChillLT> | <#MonthWChillLD>
Temp. app. max. | <#MonthAppTempH> | <#MonthAppTempHT> | <#MonthAppTempHD>
Temp. app. min. | <#MonthAppTempL> | <#MonthAppTempLT> | <#MonthAppTempLD>
Point rosée max. | <#MonthDewPointH> | <#MonthDewPointHT> | <#MonthDewPointHD>
Point rosée min. | <#MonthDewPointL> | <#MonthDewPointLT> | <#MonthDewPointLD>
+Haut min. quotidien | <#MonthMinTempH> | N/D | <#MonthMinTempHD>
+Bas max. quotidien | <#MonthMaxTempL> | N/D | <#MonthMaxTempLD>
+Haute pression | <#MonthPressH> | <#MonthPressHT> | <#MonthPressHD>
+Basse pression | <#MonthPressL> | <#MonthPressLT> | <#MonthPressLD>
+Haute humidité | <#MonthHumH> | <#MonthHumHT> | <#MonthHumHD>
+Basse humidité | <#MonthHumL> | <#MonthHumLT> | <#MonthHumLD>
Rafale max. | <#MonthGustH> | <#MonthGustHT> | <#MonthGustHD>
Vitesse vent max. | <#MonthWindH> | <#MonthWindHT> | <#MonthWindHD>
Cours du Vent max quo. | <#MonthWindRunH> | N/D | <#MonthWindRunHD>
+Forte averse | <#MonthRainRateH> | <#MonthRainRateHT> | <#MonthRainRateHD>
+Forte averse/1h | <#MonthHourlyRainH> | <#MonthHourlyRainHT> | <#MonthHourlyRainHD>
+Forte averse/1jr | <#MonthDailyRainH> | N/D | <#MonthDailyRainHD>
Nb jour max sans pluie | <#MonthLongestDryPeriod> | N/D | <#MonthLongestDryPeriodD>
Nb jour max de pluie | <#MonthLongestWetPeriod> | N/D | <#MonthLongestWetPeriodD>
Écart de Temp max. | <#MonthHighDailyTempRange> | N/D | <#MonthHighDailyTempRangeD>
Écart de Temp min. | <#MonthLowDailyTempRange> | N/D | <#MonthLowDailyTempRangeD>

Il y a aussi un ensemble de balises pour les minimums et maximums de l'année en cours. Vous pouvez personnaliser le format des dates et heures en utilisant le paramètre 'format' sur la Balise Web, voir ci-dessous.

Description | Valeur | Heure (format court) | Date (jour et mois long)
Température maximale | <#YearTempH> | <#YearTempHT> | <#YearTempHD>
Basse Température minimale | <#YearTempL> | <#YearTempLT> | <#YearTempLD>
Indice chaleur max. | <#YearHeatIndexH> | <#YearHeatIndexHT> | <#YearHeatIndexHD>
Ref. Éolien min. | <#YearWChillL> | <#YearWChillLT> | <#YearWChillLD>
Temp. app. max. | <#YearAppTempH> | <#YearAppTempHT> | <#YearAppTempHD>
Temp. app. min. | <#YearAppTempL> | <#YearAppTempLT> | <#YearAppTempLD>
Point rosée max. | <#YearDewPointH> | <#YearDewPointHT> | <#YearDewPointHD>
Point rosée min. | <#YearDewPointL> | <#YearDewPointLT> | <#YearDewPointLD>
+Haut min. quotidien | <#YearMinTempH> | N/D | <#YearMinTempHD>
+Bas max. quotidien | <#YearMaxTempL> | N/D | <#YearMaxTempLD>
Pression maximum | <#YearPressH> | <#YearPressHT> | <#YearPressHD>
Pression minimum | <#YearPressL> | <#YearPressLT> | <#YearPressLD>
Humidité maximum | <#YearHumH> | <#YearHumHT> | <#YearHumHD>
Humidité minimum | <#YearHumL> | <#YearHumLT> | <#YearHumLD>
Rafale max. | <#YearGustH> | <#YearGustHT> | <#YearGustHD>
Vitesse vent max. | <#YearWindH> | <#YearWindHT> | <#YearWindHD>
Course max. du vent | <#YearWindRunH> | N/A | <#YearWindRunHD>
Averse maximale | <#YearRainRateH> | <#YearRainRateHT> | <#YearRainRateHD>
Pluie max. en 1h. | <#YearHourlyRainH> | <#YearHourlyRainHT> | <#YearHourlyRainHD>
+Forte averse/1jr | <#YearDailyRainH> | N/D | <#YearDailyRainHD>
+Forte averse/mois | <#YearMonthlyRainH> | N/D | <#YearMonthlyRainHD>
Nb jour max sans pluie | <#YearLongestDryPeriod> | N/A | <#YearLongestDryPeriodD>
Nb jour max de pluie | <#YearLongestWetPeriod> | N/A | <#YearLongestWetPeriodD>
Écart de Temp max. | <#YearHighDailyTempRange> | N/A | <#YearHighDailyTempRangeD>
Écart de Temp min. | <#YearLowDailyTempRange> | N/A | <#YearLowDailyTempRangeD>

Il y a un ensemble de Balises pour les 'données historique récentes', qui offrent les données antérieures d'il y a 1 minute, jusqu'à il y a 1 semaine, en incrément de 1 minute. Notez que ces valeurs sont initialisées à partir des fichiers journaux de Cumulus au démarrage, donc ils auront au départ une résolution selon l'intervale de l'enregistreur de donnéeé que vous avez fixé dans Cumulus et/ou votre station. Vous recevrez la valeur la plus près si vous demandez une donnée pour lequel il n'y a actuellement pas de correspondance exacte.

Vous spécifiez de combien de temps doit dater votre valeur à l'aide de paramètres sur les Balises Web selon un nombre de jours, d'heures, et de minutes. Par exemple <#RecentOutsideTemp m=1>, donnera la température il y a une minute, <#RecentOutsideTemp h=1>donnera la température il y a une heure (tout comme <#RecentOutsideTemp m=60>), et <#RecentOutsideTemp d=1> donnera la température il y a un jour. <#RecentOutsideTemp d=1 h=1 m=1> donnera la température un jour, une heure et une minute. Toutes les valeurs fournies comme paramètres doivent être des nombres entiers. Si vous ne fournissez aucun paramètre, le résultat est non défini.

Description | Valeur
Température extérieure | <#RecentOutsideTemp>
Vitesse du vent | <#RecentWindSpeed>
Rafale de vent | <#RecentWindGust>
Vent récent | <#RecentWindLatest>
Notez: Ces 3 Balises sont la signification habituelle du vent dans Cumulus, soit: 'Speed', 'Gust' et 'Latest'.
Direction (instantané) | <#RecentWindDir>
Direction (moyenne) | <#RecentWindAvgDir>
Refroidissement éolien | <#RecentWindChill>
Point de rosée | <#RecentDewPoint>
Indice de chaleur | <#RecentHeatIndex>
Humidité relative | <#RecentHumidity>
Pression au niveau de la mer | <#RecentPressure>
Pluie jusqu'à présent, auj. | <#RecentRainToday>
Radiation solaire | <#RecentSolarRad>
Indice UV | <#RecentUV>
Date et heure | <#RecentTS>

RecentTS utilise les même paramètres que les autres balises et fournie la date et l'heure de la donnée récente demandée. Elle supporte aussi le paramètre 'format'

Il y a aussi un ensemble de Balises correspondant aux Balises 'récentes" ci-dessus, mais dont le format décimal a été changé pour y remplacer la virgule par un point, pour les items dont la valeur n'est pas entière, c'est-à-dire:
<#RCRecentOutsideTemp> <#RCRecentWindSpeed> <#RCRecentWindGust> <#RCRecentWindLatest> <#RCRecentWindChill> <#RCRecentDewPoint> <#RCRecentHeatIndex> <#RCRecentPressure> <#RCRecentRainToday> <#RCRecentUV>

Un ensemble de balises fourni les unités de mesure utilisées :<#windunit>, <#rainunit>, <#windrununit>, <#tempunit>, <#pressunit>. Notez que la Balise <#tempunit> inclue le symbole degré. La Balise <#tempunitnodeg> fournit seulement l'unité de mesure utilisée, soit, F ou C. La Balise <#cloudbaseunit> donne l'unité de mesure utilisée pour le couvert nuageux.

Il ya un ensemble de balises pour les capteurs supplémentaires :

<#ExtraTemp1> | Canal de température Supplémentaire 1 Exemple: 0,0
<#ExtraTemp2> | Canal de température Supplémentaire 2 Exemple: 0,0
<#ExtraTemp3> | Canal de température Supplémentaire 3 Exemple: 0,0
... ainsi de suite, jusqu'à <#ExtraTemp10>
<#ExtraDP1> | Canal supplémentaire point de rosée 1 Exemple: 0,0
<#ExtraDP2> | Canal supplémentaire point de rosée 2 Exemple: 0,0
<#ExtraDP3> | Canal supplémentaire point de rosée 3 Exemple: 0,0
... ainsi de suite, jusqu'à <#ExtraDP10>
<#ExtraHum1> | canal humidité Supplémentaire 1 Exemple: 0
<#ExtraHum2> | canal humidité Supplémentaire 2 Exemple: 0
<#ExtraHum3> | canal humidité Supplémentaire 3 Exemple: 0
... ainsi de suite, jusqu'à <#ExtraHum10>
<#SoilTemp1> | Température du sol 1
<#SoilTemp2> | Température du sol 2
... ainsi de suite, jusqu'à <#SoilTemp4>
<#SoilMoisture1> | Humidité du sol 1
<#SoilMoisture2> | Humidité du sol 2
... ainsi de suite, jusqu'à <#SoilMoisture4>
<#LeafTemp1> | Température du feuillage 1
<#LeafTemp2> | Température du feuillage 2
<#LeafWetness1> | Humidité du feuillage 1
<#LeafWetness2> | Humidité du feuillage 2

Il y a un ensemble de balises pour les états d'alarme de Cumulus. Ils donnent une valeur de '1' si l'alarme a été activée et la condition d'alarme est actuellement remplie; autrement '0'.

<#LowTempAlarm> | Alarme de température basse Exemple: 0
<#HighTempAlarm> | Alarme de température élevée Exemple: 0
<#TempChangeUpAlarm> | Alarme d'augmentation de la température Exemple: 0
<#TempChangeDownAlarm> | Alarme de chute de la température Exemple: 0
<#LowPressAlarm> | Alarme de pression basse Exemple: 0
<#HighPressAlarm> | Alarme de pression haute Exemple: 0
<#PressChangeUpAlarm> | Alarme de hausse de la pression Exemple: 0
<#PressChangeDownAlarm> | Alarme de baisse de la pression Exemple: 0
<#HighRainTodayAlarm> | Alarme haute pluie aujourd'hui Exemple: 0
<#HighRainRateAlarm> | Alarme haute intensité des précipitations Exemple: 0
<#HighWindGustAlarm> | Alarme haute rafales de vent Exemple: 0
<#HighWindSpeedAlarm> | Alarme haute vitesse du vent Exemple: 0

Statistique Réception Davis (Applicable aux stations Davis seulement)

Tous les chiffres sont remis à zéro quand Cumulus démarre, et sont mis à jour aux 15 minutes. Notez que ce sont simplement les chiffres fournis par la station (elles sont également disponibles sur la console). Cumulus lit et affiche simplement. Svp ne me demandez pas de les interpréter pour vous; si vous avez des soucis ou des questions au sujet de ces chiffres, entrez en contact avec Davis svp.

<#DavisTotalPacketsReceived> | Nombre total de paquets de données reçues
<#DavisTotalPacketsMissed> | Nombre de paquets de données manquées
<#DavisNumberOfResynchs> | Nombre de fois que la console s'est resynchronisée avec l'émetteur
<#DavisMaxInARow> | Plus longue série de paquets consécutifs reçus
<#DavisNumCRCerrors> | Nombre de paquets reçus avec erreur CRC

Il y a un ensemble de balises où la virgule décimale a été remplacée par un point, lorsque nécessaire, pour l'utilisation avec les jauges etc qui n'aiment pas les virgules. Elles correspondent toutes à la même balise sans le 'RC'.

<#RCdew> <#RCheatindex> <#RChum> <#RCinhum> <#RCintemp> <#RCpress> <#RCpressTH>
<#RCpressTL> <#RCrfall> <#RCrrate> <#RCrrateTM> <#RCtemp> <#RCtempTH> <#RCtempTL>
<#RCwchill> <#RCwgust> <#RCwgustTM> <#RCwspeed> <#RCwlatest> <#RCdewpointTH>
<#RCdewpointTL> <#RCwchillTL> <#RCheatindexTH> <#RCapptempTH> <#RCapptempTL>

Il y a un ensemble de balises donnant des informations système, dans un format fixe :

<#OsVersion> | Version du système d'exploitation. Exemple: Windows 7 x64 build 7600
<#OsLanguage> | Langue du système d'exploitation. Exemple: Français
<#SystemUpTime> | Depuis combien de temps le PC est allumé. Exemple: 8 hours 21 minutes
<#ProgramUpTime> | Depuis combien de temps Cumulus est-il en fonction? Exemple: 7 hours 55 minutes
<#CpuName> | Type de CPU Exemple: Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz
<#CpuCount> | Nombre de processeur Exemple: 4
<#MemoryStatus> | Mémoire vive Totale et Libre. Exemple: 4619/8191 MB (free/total)
<#DisplayMode> | Mode vidéo Exemple: 1920x1080, 32 bit
<#AllocatedMemory> | La quantité de mémoire vive allouée à Cumulus. Notez que ce n'est pas la quantité de mémoire que Cumulus utilise vraiment; c'est la quantité de mémoire actuellement allouée par Windows et que Cumulus pourrait utiliser s'il en a besoin. Exemple: 18.76 MB
<#DiskSize> | Taille du disque sur lequel Cumulus est installé. Exemple: 931.51 GB
<#DiskFree> | Espace libre sur le disque ou est installé Cumulus. Exemple: 515.36 GB

Finalement, il y a un ensemble de balises donnant des informations diverses :

<#version> | La version de Cumulus utilisée Exemple: 1.9.3
<#build> | La sous version de Cumulus (build) utilisée Exemple: 1059
<#interval> | Intervale des téléversements en minutes Exemple: 15
<#update> | La date et l'heure du dernier téléversement sur le site Web Exemple: 2010-10-09 14:13:37
<#stationtype> | Le type de station utilisé Exemple: National Geographic 265nc
<#latitude> | Latitude de la station. L'affichage par défaut est une chaîne de carartère encodée web de degrés/minutes/secondes. Comporte un paramètre facultatif 'dp' affichant en degré décimal avec un nombre défini de décimales, ex. <#latitude dp=5> pourrait donner 53.12345. Les valeurs négatives représentent 'au sud de l'équateur'. Si le paramètre 'dp' a été spécifié, alors fournir en plus "rc=y" convertira la virgule décimale en point.
<#longitude> | Longitude de la station. L'affichage par défaut est une chaîne de carartère encodée web de degrés/minutes/secondes. Comporte un paramètre facultatif 'dp' affichant en degré décimal avec un nombre défini de décimales, ex. <#longitude dp=5> pourrait donner -75.12345. Les valeurs négatives représentent 'à l'ouest du premier méridien'. Si le paramètre 'dp' a été spécifié, alors fournir en plus "rc=y" convertira la virgule décimale en point.
<#altitude> | Altitude de la station Exemple: 0 ft
<#location> | Localisation de la station Exemple: Météo St-Ours
<#longlocation> | Description plus détaillée de l'emplacement de la station Exemple: Station météo amateur située à St-Ours-sur-Richelieu
<#sunrise> | Heure courante du lever de soleil à la station Exemple: 07:00
<#sunset> | Heure courante du coucher de soleil à la station Exemple: 18:17
<#daylength> | Durée de la journée en heures et minutes (du lever au coucher du soleil) Exemple: 11:17
<#tomorrowdaylength> | Une chaîne donnant la différence entre la longueur du jour d'aujourd'hui et de demain. Exemple: There will be 3min 11s less daylight tomorrow
<#dawn> | Début du jour Civil sur la station Exemple: 06:30
<#dusk> | Fin du jour Civil sur la station Exemple: 18:46
<#daylightlength> | Durée de la lumière du jour en heures et minutes (de l'aube au crépuscule) Exemple: 12:16
<#moonphase> | Phase lunaire actuelle Exemple: premier croissant
<#MoonPercent> | Pourcentage actuel de lune visible (la valeur négative indique 'le fait de diminuer') Exemple
<#MoonPercentAbs> | Pourcentage actuel de lune visible (toujours positif) Exemple:
<#MoonAge> | 'Age' APPROXIMATIVE de la lune, en jours (0-29)
<#moonrise> | Heure actuelle du lever de la lune à la station Exemple: 09:28
<#moonset> | Heure actuelle du coucher de la lune à la station Exemple: 18:51
<#forum> | URL du forum Exemple: <a href="http://sandaysoft.com/forum/">forum</a>
<#webcam> | URL de la webcam Exemple: <a href="http://sandaysoft.com/webcam/">Webcam</a>
<#recordsbegandate> | La date à laquelle a commencé la comptabilisation des données. Exemple: 24 juillet 2010
<#DaysSinceRecordsBegan> | Le nombre de jours depuis le'enregistrement a commencé (c-à-d depuis que vous avez commencé à utiliser Cumulus)
<#graphperiod> | Le nombre d'heures affiché par les graphiques Exemple: 12
<#realtimeinterval> | Intervalle des mise à jour en temps réel, en secondes. Exemple: 45
<#rollovertime> | L'heure à laquelle l'enregistrement d'une journée débute: 'Midnight', '9 am' ou '10 am'. Exemple: midnight
<#forecastnumber> | Le nombre correspondant à la prévision actuelle dans le fichier strings.ini. Un nombre négatif signifie "exceptionnel", 0 (zéro) indique pas de prévision Cumulus Exemple: 21
<#isdaylight> | 1 si actuellement dans les heures du jour, autrement 0.
<#IsSunUp> | Retourne 1 si le soleil est levé (c'est-à-dire actuellement entre le lever et le coucher du soleil), sinon retourne 0
<#sensorcontactlost> | 1 si la station a perdu contact avec ses capteurs, 0 si le contact a été établi "Fine Offset seulement"
<#DataStopped> | 1 si la station a apparemment cessé d'envoyer des données à Cumulus, autrement 0
<#newrecord> | 1 si l'indicateur lumineux 'nouveau record' clignotte, sinon valeur 0.
<#ErrorLight> | 1 si l'indicateur 'error' clignotte, sinon 0
<#LatestError> | La dernière erreur notée dans la fenêtre d'historique d'erreurs. Chaîne vide lorsque la lumière d'erreur est cliquée et quand le Cumulus redémarre
<#LatestErrorDate> | La date de la dernière erreur notée dans la fenêtre d'historique d'erreurs, en utilisant le format de date court du système . Donne des tirets quand la dernière erreur est réinitialisée.
<#LatestErrorTime> | L'heure de la dernière erreur notée dans la fenêtre d'historique d'erreurs, en utilisant le format de date court du système . Donne des tirets quand la dernière erreur est réinitialisée.
<#TempRecordSet> | 1 si l'indicateur sur l'onglet de température sur l'écran des records absolus est actuellement allumé, 0 sinon.
<#WindRecordSet> | 1 si l'indicateur sur l'onglet des vents à l'écran des records absolus est actuellement allumé, 0 sinon.
<#RainRecordSet> | 1 si l'indicateur sur l'onglet des pluie à l'écran des records absolus est actuellement allumé, 0 sinon.
<#HumidityRecordSet> | 1 si l'indicateur sur l'onglet de l'humidité à l'écran des records absolus est actuellement allumé, 0 sinon.
<#PressureRecordSet> | 1 si l'indicateur sur l'onglet de pression à l'écran des records absolus est actuellement allumé, 0 sinon.
<#HighTempRecordSet> | 1 si l'indicateur de température maximale record clignotte actuellement, 0 sinon.
<#LowTempRecordSet> | 1 si l'indicateur de température minimale record clignotte actuellement, 0 sinon.
<#HighAppTempRecordSet> | 1 si l'indicateur de température apparente maximale record clignotte actuellement, 0 sinon.
<#LowAppTempRecordSet> | 1 si l'indicateur de température apparente minimale record clignotte actuellement, 0 sinon.
<#HighHeatIndexRecordSet> | 1 si l'indicateur d'indice de chaleur minimale record clignotte actuellement, 0 sinon.
<#LowWindChillRecordSet> | 1 si l'indicateur de Refroidissement éolien minimal record clignotte actuellement, 0 sinon.
<#HighDewPointRecordSet> | 1 si l'indicateur de point de rosée maximal record clignotte actuellement, 0 sinon.
<#LowDewPointRecordSet> | 1 si l'indicateur de point de rosée minimal record clignotte actuellement, 0 sinon.
<#HighMinTempRecordSet> | 1 si l'indicateur de température maximale minimum record clignotte actuellement, 0 sinon.
<#LowMaxTempRecordSet> | 1 si l'indicateur de température minimale maximum record clignotte actuellement, 0 sinon.
<#HighWindGustRecordSet> | 1 si l'indicateur de rafale maximale record clignotte actuellement, 0 sinon.
<#HighWindSpeedRecordSet> | 1 si l'indicateur de vitesse de vent record clignotte actuellement, 0 sinon.
<#HighRainRateRecordSet> | 1 si l'indicateur de taux de pluie record clignotte actuellement, 0 sinon.
<#HighHourlyRainRecordSet> | 1 si l'indicateur de taux de pluie record (sur 1 heure) clignotte actuellement, 0 sinon.
<#HighDailyRainRecordSet> | 1 si l'indicateur de taux de pluie record (pour 1 jour) clignotte actuellement, 0 sinon.
<#HighMonthlyRainRecordSet> | 1 si l'indicateur de taux de pluie mensuel record clignotte actuellement, 0 sinon.
<#HighHumidityRecordSet> | 1 si l'indicateur d'humidité maximale record clignotte actuellement, 0 sinon.
<#LowHumidityRecordSet> | 1 si l'indicateur d'humidité minimale record clignotte actuellement, 0 sinon.
<#HighPressureRecordSet> | 1 si l'indicateur de pression maximale record clignotte actuellement, 0 sinon.
<#LowPressureRecordSet> | 1 si l'indicateur de pression minimale record clignotte actuellement, 0 sinon.
<#HighWindrunRecordSet> | 1 Si la lumière 'highest daily wind run' clignote actuellement, 0 sinon
<#LongestDryPeriodRecordSet> | 1 Si la lumière 'longest dry period' clignote actuellement, 0 sinon
<#LongestWetPeriodRecordSet> | 1 Si la lumière 'longest wet period' clignote actuellement, 0 sinon
<#HighTempRangeRecordSet> | 1 Si la lumière 'high daily temperature range' clignote actuellement, 0 sinon
<#LowTempRangeRecordSet> | 1 Si la lumière 'low daily temperature' clignote actuellement, 0 sinon
<#DavisFirmwareVersion> | Version de 'firmware" de la console (stations Davis seul.)
<#LastDataReadT> | Horodate de la dernière lecture de données de la station effectuée par Cumulus (Les paramètres de format sont permit)

Paramètres

La plupart des dates et/ou heures ont un paramètre 'de format' optionnel, par ex : <#YearTempHT format=hh:nn>. Cela vous permet de passer outre au format par défaut pour cette balise, en utilisant les paramètres de format dans la table ci-dessous. Notez que si le format comporte des espaces, vous devez les entourer de guillements, ainsi : <#YearTempHT format = "dd mm">. Notez aussi que vous pouvez spécifier le format de date aux heures et vice versa, mais cela ne produira pas toujours des résultat corrects.

Vous pouvez inclure tout ce qui n'est pas utilisé comme caractère de formattage de date et d'heure dans les guillemets simples pour l'empêcher d'être interprété comme formateur de date ou d'heure. Par exemple, le mot on contient le caractère n, qui sera interprété comme un formateur de temps à moins que vous le mettiez entre guillemets simples. Exemple : <#TtempH format="'at' hh: mm 'on' dd / mm / yyyy">

Paramètre | Affichage
c | Affiche la date en utilisant le format donné par le format de Date Court de Windows , suivi par l'heure en utilisant le format donné par le format de Longue période de Windows. Le temps n'est pas affiché si la valeur fois de date indique le minuit avec précision.
d | Affiche le jour en nombre sans le zéro (1-31).
dd | Affiche le jour en nombre sur 2 positions (01-31).
ddd | Affiche le jour en abrégé (Sun-Sat). Selon la configuration régional de Windows
dddd | Affiche le jour en texte (Sunday-Saturday). Selon la configuration régionale de Windows
ddddd | Affiche le jour en selon le format de date court de Windows.
dddddd | Affiche le jour en selon le format de date long de Windows.
m | Affiche le mois en nombre sans le zéro (1-12). Si le paramètre m suit tout de suite un paramètre h ou hh , la minute plutôt que le mois est affichée
mm | Affiche le mois en nombre (01-12). Si le paramètre m suit tout de suite un paramètre h ou hh , la minute plutôt que le mois est affichée
mmm | Affiche le mois en abrégé (Jan-Dec). Selon la configuration régional de Windows
mmmm | Affiche le mois en texte (Janvier-Decembre). Selon la configuration régional de Windows
yy | Affiche l'année en nombre sur 2 positions (00-99).
yyyy | Affiche l'année en nombre sur 4 positions (0000-9999).
h | Affiche l'heure en nombre sans le zéro (0-23).
hh | Affiche l'heure en nombre sur 2 positions (00-23).
n | Affiche les minutes en nombre sans le zéro (0-59).
nn | Affiche les minutes en nombre sur 2 positions (00-59).
s | Affiche les secondes en nombre sans le zéro (0-59).
ss | Affiche les secondes en nombre sur 2 positions (00-59).
z | Affiche les milisecondes en nombre sans le zéro (0-999).
zzz | Affiche les milisecondes en nombre sur 3 positions (00-999).
t | Affiche l'heure selon le format heure court de Windows.
tt | Affiche l'heure selon le format heure long de Windows.
am/pm | Utilise le format 12 heures du paramètre h ou hh précédent et affiche 'am' pour n'importe quelle heure avant midi et 'pm' pour n'importe quelle heure après midi. Le paramètre am/pm peut utiliser les minuscules, majuscules, ou un mélange des deux et le résultat est affiché en conséquence.
a/p | Utilise le format 12 heures du paramètre h ou hh précédent et affiche 'a' pour n'importe quelle heure avant midi et 'p' pour n'importe quelle heure après midi. Le paramètre am/pm peut utiliser les minuscules, majuscules, ou un mélange des deux et le résultat est affiché en conséquence.
ampm | Utilise le format 12 heures du paramètre h ou hh précédent et affiche la chaîne de caractère AM de Windows pour n'importe quelle heure avant midi et la chaîne de caractère AM de Windows pour n'importe quelle heure après midi.
/ | Affiche le caractère de séparation de date fourni par le format de date Windows.
: | Affiche le caractère de séparation d'heure fourni par le format heure de Windows.
'xx' | Les caractères entre apostrophes sont affichés tel quels et n'affectent pas le formattage.


Fichiers historique

Cumulus crée deux jeux de fichiers historique, stockés dans le répertoire ou vous avez installé Cumulus, dans le sous-dossier data.

Le premier est un fichier unique nommé dayfile.txt; un enregistrement est ajouté chaque jour à minuit, ou 09H00 (10h00 en été) selon le paramêtrage choisi à l'écran Configuration Station, résumant les données de la journée. Les données sont séparées par une virgule, et chaque écriture contien les champs suivants, dans cet ordre :

  • Date au format jj/mm/aa (la barre oblique peut être remplacée par un tiret parfois).
  • Plus forte rafale
  • Direction de la plus forte rafale
  • Heure de la plus forte rafale
  • Température minimale
  • Heure de la température minimale
  • Température maximum
  • Heure de la Température maximum
  • Pression minimum, au niveau de la mer
  • Heure de la Pression minimum
  • Pression maximum, au niveau de la mer
  • Heure de la Pression maximum
  • Taux de pluie Maximum
  • Heure du taux maximum
  • Précipitations totales du jour
  • Température moyenne du jour
  • Course du vent totale
  • Plus fort vent, en moyenne
  • Heure du plus fort vent moyen
  • Plus basse humidité
  • Heure de la plus basse humidité
  • Plus haute himidité
  • Heure de la plus haute humidité
  • Évatransportation totale
  • Nombre d'heures d'ensoleillement
  • Plus haut indice de chaleur
  • Heure du plus haut indice de chaleur
  • Plus haute température apparente
  • Heure de la plus haute température apparente
  • Plus basse température apparente
  • Heure de la plus basse température apparente
  • Plus forte pluie en 1 heure
  • Heure de la plus forte pluie en 1h
  • Plus basse température avec Facteur Éolien
  • Heure du plus bas Facteur Éolien
  • Point de rosée maximal
  • Heure du point de rosée maximal
  • Point de rosée minimal
  • Heure du point de rosée minimal
  • Direction dominante du vent
  • Degré jour chauffage
  • Degré jour climatisation
  • Radiation solaire maximale
  • Heure de la radiation solaire maximale
  • Indice UV maximum
  • Heure de l'indice UV maximum

Le deuxième fichier consiste en plusieurs fichiers nommé ainsi: <Mois><Année>log.txt (Par exemple, pour décembre 2010, le fichier est Dec10log.txt). Un enregistrement est ajouté au fichier mensuel courant toutes les 15 minutes (selon la configuration). Cet enregistrement contient les valeurs en cours des capteurs. Les données sont séparées par des virgules, et chaque enregistrement contient les éléments suivants, dans cet ordre :

  • Date au format jj/mm/aa (la barre oblique peut être remplacée par un tiret parfois).
  • Heure courante
  • Température extérieure
  • Humidité
  • Point de rosée
  • Vitesse du vent
  • Rafale (moy. sur 10 mins)
  • Direction du vent en moyenne
  • Taux de pluie
  • Pluies totale du jour, pour l'instant
  • Pression atmosphérique
  • Pluies totales, sur la console
  • Température intérieure
  • humidité intérieure
  • Dernière rafale
  • Refroidissement éolien
  • Indice de chaleur
  • Indice UV
  • Radiation solaire
  • Évatransportation
  • Évatransportation annuel
  • Température ressentie
  • Radiation solaire maximum théorique
  • Nb heures de soleil pour l'instant aujourd'hui
  • Direction courante du vent
  • Pluie aujourd'hui, si capteur RG-11
  • Pluie depuis minuit

L'heure dans ces fichiers est au format hh:mm, sur 24 heures, synchronisé à l'heure locale de votre Pc. Toutes les données sont enregistrées dans le format défini par l'utilisateur à l'écran de configuration de la station. Notez que nous employons le terme "séparé par des virgules", même si dans plusieurs cas, le séparateur peut être un "point-virgule" ou un autre caractère selon la configuration de votre système.

Optionnellement, si des capteurs supplémentaires sont définis dans les paramètres de la station, un jeu de fichiers sera créé avec un nom défini ainsi: ExtraLogyyyymm.txt (par exemple, le fichier pour le mois de décembre 2013 seait nommé ExtraLog201312.txt ); une écriture est faite dans le fichier du mois courant à chaque 10 minutes (selon l'intervale configuré), pour y inscrire la valeur courante du capteur supplémentaire. Le fichier est aussi délimité par des virgules et chaque entrée contient les champs suivants, dans cet ordre:

  • Date au format jj/mm/aa (la barre oblique peut être remplacée par un tiret parfois).
  • Heure courante
  • 10 valeurs supplémentaires de température
  • 10 valeurs supplémentaires d'humidité
  • 10 valeurs supplémentaires de point de rosée
  • 4 valeurs de température du sol
  • 4 valeurs d'humidité du sol
  • 2 valeur de température du feuillage
  • 2 valeur d'humidité du feuillage

Si l'option temps réel est sélectionnée, Cumulus crée le fichier realtime.txt à l'interval choisi, et si counfiguré pour ce faire, l'envoi sur votre site Web. Le format de ce fichier est le suivant:

Example: 18/10/08 16:03:45 8.4 84 5.8 24.2 33.0 261 0.0 1.0 999.7 W 6 mph C mb mm 146.6 +0.1 85.2 588.4 11.6 20.3 57 3.6 -0.7 10.9 12:00 7.8 14:41 37.4 14:38 44.0 14:28 999.8 16:01 998.4 12:06 1.8.2 448 36.0 10.3 10.5 13 0.2 14 260 2.3 13 1 0 NNW 2040 ft 12.3 11.1 420.1 1

Champ | Exemple | Description
1 | 18/10/08 | date jj/mm/aa
2 | 16:03:45 | Heure hh:mm:ss
3 | 8.4 | température extérieure
4 | 84 | humidité relative
5 | 5.8 | point de rosée
6 | 24.2 | Vitesse du vent (moyenne)
7 | 33.0 | Vitesse du vent ('latest')
8 | 261 | Direction du vent
9 | 0.0 | Taux de pluie horaire actuel
10 | 1.0 | Pluie du jour
11 | 999.7 | Baromètre
12 | W | Direction du vent
13 | 6 | Vitesse du vent (beaufort)
14 | mph | Unité de vitesse du vent
15 | C | Unité de température
16 | mb | Unité de pression
17 | mm | Unité de pluie
18 | 146.6 | Course du vent aujourd'hui
19 | +0.1 | Tendance de pression
20 | 85.2 | Pluie du mois
21 | 588.4 | Pluie de l'année
22 | 11.6 | Pluie d'hier
23 | 20.3 | Température intérieure
24 | 57 | Humidité intérieure
25 | 3.6 | Facteur Éolien
26 | -0.7 | Tendance de température
27 | 10.9 | Température la plus élevée du jour
28 | 12:00 | Heure de la Température la plus élevée du jour
29 | 7.8 | Température la plus basse du jour
30 | 14:41 | Heure de la Température la plus basse du jour
31 | 37.4 | Plus fort vent (moyen) du jour
32 | 14:38 | Heure du Plus fort vent (moyen) du jour (hh :mm)
33 | 44.0 | Plus forte rafale du jour
34 | 14:28 | Heure de la Plus forte rafale du jour
35 | 999.8 | Plus forte pression du jour
36 | 16:01 | Heure de la Plus forte pression du jour: mm)
37 | 998.4 | Plus basse pression du jour
38 | 12:06 | Heures de la Plus basse pression du jour
39 | 1.8.2 | Version de Cumulus
40 | 448 | Sous-Version ('build') de Cumulus
41 | 36.0 | Plus forte rafale récente (moy 10 mins)
42 | 10.3 | Indice de chaleur
43 | 10.5 | Humidex
44 | 13 | Indice UV
45 | 0.2 | Évatransportation aujourd'hui
46 | 14 | Radiation solaire W/m2
47 | 260 | Direction du vent (moy sur 10 mins, en degré)
48 | 2.3 | Averse la dernière heure
49 | 13 | No. de la prévision actuelle (voir samplestrings.ini). Une valeure négative indique "Exceptionnel"
50 | 1 | Est-le jour? 1 si pendant les heures de lumière du jour (entre l'aube et le crépuscule, sinon 0
51 | 0 | Contact perdu avec les capteurs (1=oui)(FineOffset seul.)
52 | NNW | Direction du vent (moyenne)
53 | 2040 | Altitude du couvert nuageux
54 | ft | Unité de mesure du couvert nuageux
55 | 12.3 | Température ressentie
56 | 11.1 | Heures d'ensoleillement pour l'instant, aujourd'hui
57 | 420.1 | Radiation solaire maximum théorique actuel
58 | 1 | Est-ce que le soleil brille? 1 si ensoleillé, autrement 0 (requière un capteur solaire)

Cumulus garde aussi un historique des changements aux records absolus, appelés alltimelog.txt, qui peut être trouvé dans le répertoire data. Une entrée est ajoutée à chaque fois qu'un record absolu change, avec les détails des anciens et nouveaux records. Cet historique peut alors être utilisé pour 'rembobiner' si de fausses données engendrent un nouveau record absolu incorrect. C'est aussi un historique utile quand les records ont été vraiment battus.

Le format d'entrées dans cet historique va comme suit :

date heure valeur "nom de l'item" ancienne date ancienne heure ancienne valeur

Les dates sont au format ISO (yyyy-mm-dd) et les heuress sont en format hh:mm de 24 heures (le séparateur est toujours des deux-points, sans tenir compte des paramètres système) et les valeurs sont toujours à trois décimales. Vous devriez arrondir les valeurs de façon appropriée lors de son utilisation. Les guillemets encadrent les noms d'item. Un exemple :

2010-02-24 05:19 -7.600 "Lowest temperature" 2009-02-09 04:50 -6.500


Section : Affichages

Logo de Cumulus Weather Software

Section : Affichage

Dans cette section, nous explorons les menus et diverses pages écran importantes dans Cumulus.

La section Affichages comporte 9 sections, à savoir:

  • Écran Principal - Description de l'écran de surveillance de Cumulus
  • Menu Principal- Le menu de Cumulus, en détails
  • Records absolus - Page écran des records
  • Ce mois - L'écran résumant l'ensemble des statistiques d'un mois.
  • Graphiques - L'écran des graphes météo.
  • Journal météo - Écran des notes pouvant accompagner les observations.
  • Select-A-Graph - Module d'analyse par graphes.
  • Éditer les records - Corriger des records erronés.
  • Éditeur Dayfile - Édite l'historique quotidien.
  • Gérer les alarmes - Fonctionnement des alarmes programmables.

Version 0.5 - Novembre 2013


Adaptations et traductions

Dans le dossier ou vous avez installé Cumulus, vous trouverez un fichier appelé 'samplestrings.ini'. Prenez-en une copie, laissez la copie dans la répertoire d'installation de Cumulus et appelez-la 'strings.ini'. Le fichier contient des textes utilisés à diffénts endroits dans Cumulus, par ex. pour les prévisions.

forecast23=Precipitation at frequent intervals

Révisez le texte comme désiré, par ex. :

forecast23=Précipitations frquentes!

ou même :

forecast23=Il pleut!

Au démarrage, Cumulus utilisera les textes que vous avez spécifié au lieu des textes par défaut. Plus de textes personalisables seront ajoutés avec le temps.

Des traductions françaises existent pour Cumulus. Visitez le Wiki, le forum et le page de téléchargement de Cumulus

Des adaptations particulières pour la Francophonie sont disponible sur Météo du Québec, dans la section CumulusFranco
Si vous maitrisez l'anglais, Weather by You! Offre plusieurs gabarits et les traductions en 13 langues!


Fenêtre "This Month"

La fenêtre "This Period"

(Menu: VIEW - THIS PERIOD)

Cette fenêtre peut être affichée en sélectionnant This Period dans le menu View. Plusieurs statistiques peuvent être affichées pour la période de votre choix.

La période désirée peut être choisi en utilisant les champs Start Date(date de début) et End Date (date de fin) puis cliquer sur le bouton Update display.

Les données affichées peuvent être copiées dans le presse-papier (pour être postées dans un article Usenet, par exemple) en cliquant sur Copy to clipboard.


Cumulus "This Month" Window

La fenêtre "This Year"

(Menu: VIEW - THIS YEAR)

Cette fenêtre peut être affichée en sélectionnant This Year à partir du menu View. Plusieurs statistiques pour l'année en cours y sont affichées.

Les années autres que celle du mois en cours peuvent être sélectionnées en utilisant la liste déroulante Year au bas de l'écran et en cliquant sur Update display.

Les données affichées peuvent être copiées dans le presse-papier (pour être posté dans un article Usenet, par exemple) en cliquant sur Copy to clipboard.

Notez que les données de l'année en cours à l'écran n'incluent pas les données du jour.